Footer broken on tablet and mobile viewport

This topic has 6 replies, 4 voices, and was last updated 1 years, 6 months ago ago by Rose Tyler

  • Avatar: IvanMTK
    IvanMTK
    Participant
    January 25, 2022 at 04:21

    We’ve been experiencing lots of issues with the footer and it’s very frustrating because this issue comes up randomly and sometimes disappears without us doing anything to fix it. We’ve previously opened a ticket regarding this problem here https://www.8theme.com/topic/footer-broken-in-mobile-view-and-doesnt-translate-well-from-desktop/#post-311798 however, after it was fixed. We noticed that it has come up again and we didn’t make any modifications to the footer for it to break. It seems like anytime we make changes to the footer static blocks, it breaks the footer on tablet/mobile and there isn’t a clear way to fix it when that happens.

    Please, contact administrator
    for this information.
    5 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    January 25, 2022 at 12:20

    Hello,

    Go to Elementor > Tools > Regenerate CSS & Data. Check the footer after that. Looks that the style file for the footer static blocks was missing or incorrectly generated.

    Regards

    Avatar: IvanMTK
    IvanMTK
    Participant
    January 26, 2022 at 07:03

    Alright that seems to have fixed it. However is there an underlying bug that causes this to happen because we noticed this issue occurs only with the footer static block.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    January 26, 2022 at 13:13

    Hello,

    Static Block is the custom Post type and Elementor added new option of the styles optimization that generates the styles only if you visit the post type page directly after changes of the content. Static block displayed in footer, it’s not the block page itself that’s why this issue appears. We are working to fix the problem but we need some time to find the solution for this issue. That’s why Regenerate CSS & Data is like temporary solution till we release update with fix of the bug.

    Regards

    Avatar: CENDO
    CENDO
    Participant
    December 21, 2022 at 15:13

    I also experience this problem but after activating W3 total cache. The footer on desktop – on some pages – is suddenly no longer good. The footer is then suddenly built up vertically and aligned all the way to the left instead of being displayed in blocks next to each other.

    What can I do to fix this?

    Greeting,
    Erwin

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    December 21, 2022 at 15:42

    Hello, @CENDO,

    I’ve disabled Static Blocks Cache on your site via Theme Options > Speed optimization.
    Please check the footer now.

    Regards

  • Viewing 6 results - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.