Incompatibility between Elementor and XStore Core

This topic has 8 replies, 4 voices, and was last updated 1 years, 11 months ago ago by Rose Tyler

  • Avatar: Eco.Seis
    Eco.Seis
    Participant
    March 25, 2022 at 18:19

    Hi.

    This is a problem that apparently affects your XStore Core plugin. Everything was working fine in our WordPress until we updated to the latest version of Elementor (which also applied an update to the DB).

    Then a critical error occurred that broke the website. We have seen that this version of Elementor works without problems together with other plugins, but if you keep the XStore Core activated then the error occurs.

    Is it possible that there is an incompatibility between both plugins in the current version? It doesn’t seem to be a bug in the Elementor plugin update as it works fine (as long as XStore Core is deactivated, but this plugin is essential for your theme to work).

    Suggestions welcome, thanks!

    Please, contact administrator
    for this information.
    7 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 26, 2022 at 08:53

    Hello,

    Update XStore Core plugin to 4.1.2.1 version –
    https://xstore.helpscoutdocs.com/article/37-plugins-update and check then.

    Regards

    Avatar: Eco.Seis
    Eco.Seis
    Participant
    March 26, 2022 at 13:17

    Hi, the update has indeed solved the problem…, it was something basic.

    What I don’t understand is why the update was not available in the WordPress installation (including the XStore/Plugins Installer location).

    That’s why it seemed to me that we already had the latest version of the plugin available.

    Regards!

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 26, 2022 at 13:37

    Hello,

    Thanks for letting us know.

    Regards

    Avatar: Alejandro Labrador Simon
    Alejandro Labrador Simon
    Participant
    August 23, 2022 at 21:11

    Good afternoon, the same thing happened to me on my website, I updated plugins and Elementor stopped working, how can I find a compatible version of Xstore code?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    August 24, 2022 at 06:51

    Hello @Alejandro Labrador Simon,

    Download XStore – Installable Archive from this page – https://www.8theme.com/downloads/ and re-upload theme files, do the case for the XStore Core plugin.
    Clear cache and check if the Elementor works fine.

    Regards

    Avatar: enimmo
    enimmo
    Participant
    August 29, 2022 at 11:37

    Hi! I am having the same issue and reinstalling the theme files has not resolved the issue, elementor still won’t load.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    August 29, 2022 at 11:58

    Hello @enimmo,

    Try to disable all the third-party plugins, that do not come bundled with XStore https://xstore.helpscoutdocs.com/article/36-included-plugins , clear cache of browser, then check. Maybe one of the additional plugins is the reason for the problem.
    If the problem is independent of 3rd party plugins, provide the URL of your site and temporary wp-admin access.
    wp-admin access: Create an account via Dashboard (Users > Add new) with administrator role http://prntscr.com/s3rc9m > provide us with username and password via the Private Content area http://prntscr.com/s5mao7 You can use any email for it.

    Regards

  • Viewing 8 results - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.