There is a problem with ajax product tabs

This topic has 11 replies, 3 voices, and was last updated 9 months, 2 weeks ago ago by Rose Tyler

  • Avatar: Mike Papadakis
    Mike Papadakis
    Participant
    October 4, 2023 at 16:21

    Hi there, it seems that there is a problem with this elementor widget.
    If you see at the home page of this site https://bizantines.webnestors.online/ everything is allright
    but if you go to this page https://bizantines.webnestors.online/home-niche-market04/ everything is broken so when I place the ajax product tabs on the first page everything goes as the second page, if I delete it all goes back to normal.

    10 Answers
    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 5, 2023 at 07:16

    Hello, @Mike Papadakis,

    1) We understand that you are experiencing an issue and we are here to assist you. To rectify this problem, please follow the steps below:

    1. Navigate to the ‘Edit Page with Elementor’.
    2. Proceed to ‘Settings of Element’.
    3. Click on ‘Advanced’.
    4. Select ‘XStore ajaxify’.
    5. Find ‘Lazy loading’ and turn it ‘Off’.
    6. Finally, update the settings.

    Please refer to the attached image for a visual guide on how to perform these steps. https://imgur.com/Zh7ZmGw

    2) Please navigate to Xstore > Theme Options > Speed optimization > Menu Dropdown Ajax Loading, Menu Dropdown Cache, Menu Cache, Static Blocks Cache and Remove Query Strings From Static Resources > Off.

    Activate the mentioned options once all changes to the site will be done.

    3) We suggest disabling all third-party plugins (including cache plugins) that do not come bundled with XStore (https://xstore.helpscoutdocs.com/article/36-included-plugins), clearing the cache of the browser, and then checking again. It is possible that one of the additional plugins is causing the issue.

    If the issue still persists, please keep all third-party plugins deactivated on your site and grant permission to debug your site, which includes deactivating all third-party plugins and on-site Customization. This will allow us to investigate and assist you accordingly.

    Please note that you should take a complete backup of your site before proceeding.

    In addition, please provide your site’s WP Admin URL and credentials in the private content area of this topic, so that we can look into it further:

    WP Admin URL:
    WP Admin Username:
    WP Admin Password:

    Thank you for your cooperation.

    Best Regards,
    8Theme’s Team.

    Avatar: Mike Papadakis
    Mike Papadakis
    Participant
    October 5, 2023 at 12:05

    Hi and thank you for your response,
    I followed all your instructions but there was no luck it still doing the same
    please you can login vis this link

    Please contact administrator
    for this information.
    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 5, 2023 at 13:35

    Hello, @Mike Papadakis,

    We appreciate the wp-admin login details you have provided.

    Upon reviewing your site, we have discovered that the issue you are experiencing is due to the activated CDN on your site and Server cache issue. https://ibb.co/WP1KPKx

    We kindly request you to completely flush your server cache and temporarily disable the Content Delivery Network (CDN) on your site for troubleshooting purposes. Please check the site again after performing these actions.

    We trust that this will rectify the issue you are experiencing.

    If the changes you make in the Customizer are not reflected on the page, it is likely a caching issue. If the changes are visible in the Customizer, they should also be visible on the front end.

    Please refer to the attached images for your reference.

    in customizer mode: https://ibb.co/b6hpMMT

    On-site frontend: https://ibb.co/bFHVtBH

    2) We kindly request that the PHP version be downgraded from 8.2 to 7.x (prior to 8) or to 8.0. We suspect that the issue may be due to the PHP version. https://ibb.co/ncJgvsC

    Best Regards,
    8Theme’s Team.

    Avatar: Mike Papadakis
    Mike Papadakis
    Participant
    October 5, 2023 at 13:57

    Hi again it seems that was a problem of php version I downgraded to 7.4 and works fine, the strange thing is that it’s working only in this version not even on 8.0, and that was from your latest theme update, I believe that you should go with at least 8.0 combability, thank you for your help

    Avatar: Mike Papadakis
    Mike Papadakis
    Participant
    October 5, 2023 at 13:58

    Also the website is not on cloudflare or having any caching from server or plugin

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 5, 2023 at 14:08

    Hello, @Mike Papadakis,

    Thank you for getting back to us and sharing your observations. We’re glad to hear that downgrading the PHP version to 7.4 resolved the issue.

    We are pleased to inform you that our theme is fully compatible with PHP 8.0. This has been confirmed through testing on our site, where we are currently utilizing PHP version 8.1.23, and the site is functioning optimally. https://imgur.com/IFuMmF8

    We would like to kindly request that you ensure the use of the most recent version of the Xstore theme (9.1.14) and the XStore core plugin (5.1.14) on your website. This will ensure optimal performance and compatibility.

    For your convenience, we have provided a link to the theme’s changelog where you can review all updates and changes: https://xstore.8theme.com/update-history/

    We appreciate your cooperation and understanding in this matter.

    Best Regards,
    8Theme’s Team.

    Avatar: Mike Papadakis
    Mike Papadakis
    Participant
    October 5, 2023 at 14:22

    Thank you for your help, I also tried to run it with php vesion 8.0 but still the same from my side, also I have the latest version of the theme and the core plugin, but you can check it out also from your side, you have still the login link

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 6, 2023 at 07:10

    Hello, @Mike Papadakis,

    Please provide FTP access, we need to check the problem more deeply.

    To create FTP access (FTP host, FTP username, FTP password, FTP port, FTP encryption) , please contact your hosting provider for assistance.

    Best Regards,
    8Theme’s Team.

    Avatar: Mike Papadakis
    Mike Papadakis
    Participant
    October 6, 2023 at 08:22

    FTP Access will be difficult due to VPS Server, please create a SSH Key and send it to me to give you access
    Here are some instructions
    https://ploi.io/documentation/ssh

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    October 7, 2023 at 09:25

    Hello, @Mike Papadakis,

    Private Content

    Best Regards,
    8Theme’s Team.

    Please contact administrator
    for this information.
  • Viewing 11 results - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.