CSS not loading correctly on shop page on mobile phones

This topic has 22 replies, 3 voices, and was last updated 1 year, 9 months ago ago by Rose Tyler

  • Avatar: FS
    FS
    Participant
    March 30, 2022 at 08:12

    Hi Support

    I’ve created a static block for my shop page header (description area). On Desktop it’s working fine but on mobile, the css is not loaded correctly. I mean I’ve defined in this static block some typo sizes etc. On mobile, it’s not loaded correctly… I will share a Video for you in private section.

    Best

    Please, contact administrator
    for this information.
    21 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    March 30, 2022 at 13:44

    Hello,

    I inspected your site and don’t see the mentioned issue https://gyazo.com/b905447f3b245a4a88c9c5e7b6d5929f
    I see that you use cache plugin. Please, always clear cache after your changes to apply them.

    Regards

    Avatar: FS
    FS
    Participant
    March 31, 2022 at 19:10

    hm i have the issue right now on the site. everytime i change something on another site, this shop slider is broken on mobile devices. i could not figure out what happens there. iβ€˜ve disabled cache plugins but it still happens…

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 1, 2022 at 07:25

    Hello,

    1/ Are you just resizing the browser window or checking on the real device? Because if you resize the window then you need to reload the page after resizing. So, either check the page on the real device or refresh the page after resizing.
    2/ Go to Elementor > Tools > Regenerate CSS & Data. Check the Shop page then.

    Regards

    Avatar: FS
    FS
    Participant
    April 2, 2022 at 13:49

    Hi Rose

    I’m checking it on a real device and also in dev mode on desktop. Everywhere I delete cache and so on, it happens the same.
    And the ugly thing. Do I change something on a different Static Block or on a Page, the shop header is destroyed. I have to open the static block from the shop header, change maybe a title, safe and delete cache. Then it’s working. After that I change something on another page, its broken again and I have to make the workarround again…
    I’ve recreated the CSS but it happens the same. What can I do? πŸ™ It’s pretty tedious when I have to make always a workarround when I just change something small on another page…

    Best

    Avatar: FS
    FS
    Participant
    April 2, 2022 at 13:58

    See private message for video of the workarround

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 2, 2022 at 20:49

    Hello,

    Keep this option disabled https://prnt.sc/9dEwo9tZRhAH and check the issue after that. Do you still have that?

    Regards

    Avatar: FS
    FS
    Participant
    April 5, 2022 at 08:11

    Hi Olga

    This option is disabled and was never active πŸ™

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 5, 2022 at 14:22

    Hello,

    No, it was enabled before my first login.
    So, do you have this issue now?

    Regards

    Avatar: FS
    FS
    Participant
    April 5, 2022 at 14:45

    Hi Olga

    Yes the error is still there :-/ I changed some stuff on the website and then the shop css was broken again…

    I saw something special. When I have directly a look on the FTP I see the folder /wp-content/uploads/elementor/css. Elementor stores it’s custom css there. When I open the page in the front end, it generates the custom css files… When I go to elementor editor and change something on the page, this custom css files are still there and gets updated, when I go to the front end… Now my question. When I change something on a static block of xstore, all the css files in the folder of elementor are completly deleted… Then it generates all the files again when I go to the front end… Maybe this is an issues with the shop page, that this css generation is broken? And I don’t know why the editing of a static block is deleting all the custom css?
    Maybe I’m completly wrong but it makes no sense…

    Best

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 5, 2022 at 16:25

    Hello,

    I see. Could you, please, provide us with FTP access to your site to check the issue in more detail?

    Regards

    Avatar: FS
    FS
    Participant
    April 6, 2022 at 16:07

    See private section

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 7, 2022 at 00:22

    Hello,

    Thank you. I passed the issue to our developers. I’ll inform you once they fix the problem.

    Regards

    Avatar: FS
    FS
    Participant
    April 21, 2022 at 13:21

    Hi Olga

    Are there any news? Because it’s still happening and pretty annoying πŸ™

    Best

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 22, 2022 at 16:00

    Hello,

    We tried to find the solution to avoid that but unfortunately with no luck. If we don’t call the default Elementor function to remove styles and generate the new one once you visit the page then all the static blocks will have broken styles.

    Regards

    Avatar: FS
    FS
    Participant
    May 11, 2022 at 12:52

    Hello Olga

    Are here any news? It’s pretty annoying when I just change a little thing and the css in the store is broken :-/

    Best

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    May 11, 2022 at 16:29

    Hello,

    Unfortunately, there is no solution for this issue. If we disable removing then it causes the issue with the static block styles in general and always, not just on the shop page.

    Regards

    Avatar: FS
    FS
    Participant
    May 12, 2022 at 13:06

    Hi Olga

    Don’t understand why it’s not working! And after 6 weeks no solution for that it’s not cool. I mean you have on your demo sites also sliders on the shop page? For example here: https://xstore.8theme.com/elementor/demos/grocery-market/shop/

    How did you do that?

    Best

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    May 13, 2022 at 13:48

    Hello,

    We have created Footer static block and added that to pages, then created Shop static block and added that to content and everything works ok. We don’t edit these blocks every time.

    Editing of the simple page does not cause any issues with these static blocks.

    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    May 13, 2022 at 13:48

    Hello,

    We have created Footer static block and added that to pages, then created Shop static block and added that to content and everything works ok. We don’t edit these blocks every time.

    Editing of the simple page does not cause any issues with these static blocks.

    Regards

  • 1 2
    Viewing 20 results - 1 through 20 (of 22 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.