WCFM Compatibility Issue Related to Livechat

This topic has 15 replies, 2 voices, and was last updated 2 years, 3 months ago ago by Olga Barlow

  • Avatar: Brisden
    Brisden
    Participant
    December 4, 2021 at 09:27

    Hi support.

    I have deleted the WCMP multivendor plugin and installed the WCFM Plugin. Most of it features are working find so far except the live chat features . I did contact the WCFM support. They gave a solution with a custom css modification code to be placed at the theme custom css section but not able to fix the issue. They told me to check with the theme support of compatibility.

    Here is the issue.
    The multivendor live chat features will appear on the single product page under the add to cart button and on the vendor store page banner.

    Issue is after the multivendor live chat module offered by WCFM is turned on. The livechat button appears on the vendor store page BUT doest appear on the single product page. On top of that, the product descriptions section completely disappears from the single product page when NO user logged in but appears when user logged in.

    The entire description section works fine the live chat module is turned off.

    Sorry for the long explanation.

    The staging site web url link attached for your referral.

    Appreciate your advice.
    TIA.

    Regards
    Admin

    Please, contact administrator
    for this information.
    14 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 6, 2021 at 10:30

    Hello,

    Could you, please, provide us with WP Dashbaord and FTP access? We’ll check the issue in more detail.

    Regards

    Avatar: Brisden
    Brisden
    Participant
    December 7, 2021 at 02:32

    Hi sure. Please refer to private area. And also I cant customise the vendor corresponding emails as they are not in the xstore email builder. Please pull out the default WCFM vendor corresponding email templates into the xstore email builder for me to make template customisation.

    Thank you.
    Best regards

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 7, 2021 at 13:40

    Hello,

    Can’t connect to your SFTP https://prnt.sc/225nnoi

    Regards

    Avatar: Brisden
    Brisden
    Participant
    December 8, 2021 at 01:42

    Sorry about that.
    Please refer to the new credentials. The site uses SFTP protocol under new site manager connection. Tested from my end. all good.

    Regards

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 8, 2021 at 11:16

    Hello,

    Thank you. I passed the issue to our developers. I’ll inform you once they fix the problem.

    Regards

    Avatar: Brisden
    Brisden
    Participant
    December 10, 2021 at 05:32

    Hi there. Waiting update.
    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 10, 2021 at 18:21

    Hello,

    Thank you for your patience. Check now, please.

    Regards

    Avatar: Brisden
    Brisden
    Participant
    December 14, 2021 at 08:11

    Hi there. Thank you for the update. Upon checking . Detected the following issues.
    1. The product descriptions, store policies, inquiries under section 4 of single product page not showing up if not logged in.
    2. The WCFM buttons are also not working if not logged in.

    Both the features are only working for logged in users.
    All the above features have to work without needing to be logged in.

    Snapshot attached.

    TIA
    Regards

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 15, 2021 at 00:24

    Hello,

    Issue is related to your cache plugin https://prnt.sc/230uk17 and server cache. It causes JS errors. So, check the plugin settings because not all the third-party plugins that you use support JS nimification and combination.

    Regards

    Avatar: Brisden
    Brisden
    Participant
    December 15, 2021 at 03:45

    Hi. Thank you for fixing that JS error issue. Appreciate it. Will keep an eye on this in the future.
    Now the product page works fine.

    But there is another related issue found on the vendor page.

    There are double inquiry button showing up on the vendor page. Please refer to the snapshot.
    This is also causing error when pulling out data of the inquiry message from the vendor dashboard.

    TIA
    Snapshot attached.
    Regards

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 15, 2021 at 17:02

    Hello,

    I see. Passed that to our developers.

    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 17, 2021 at 14:18

    Hello,

    Check now, please.

    Regards

    Avatar: Brisden
    Brisden
    Participant
    December 21, 2021 at 04:50

    Hi there. Checked. The problem resolved. Thank you for the awesome support work.

    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 21, 2021 at 17:09

    Hello,

    You are welcome.

    Regards

  • Viewing 15 results - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.