Multilanguage - by Lemontronik - on WordPress WooCommerce support

This topic has 7 replies, 3 voices, and was last updated 3 years, 1 months ago ago by Olga Barlow

  • Avatar: Lemontronik
    Lemontronik
    Participant
    April 17, 2021 at 14:14

    Hi guys, my site is multilanguage (English-Spanish), currently I have installed Polylang and Locotranslate to be able to configure the languages; but I have translated some strings of the theme in locotranslate and when I switch to the Spanish version I cannot see the translation of these strings.

    I appreciate your help to be able to correctly configure the multilanguage of my site including the language in Spanish for the royal template.

    Thank you!

    Please, contact administrator
    for this information.
    6 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 17, 2021 at 15:15

    Hello,

    Please provide temporary wp-admin access and screenshots of strings that can’t be translated.

    Regards

    Avatar: Lemontronik
    Lemontronik
    Participant
    April 17, 2021 at 16:14

    In general, I can’t translate the theme into Spanish when I switch in the language, some of the words and strings that I have tried are: (My Account, Login, Register, Search, Cart, return to previous page …)

    Thanks for your help

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 18, 2021 at 14:34

    Hello,

    Thanks for the reply.
    Provide temporary FTP access also. If you do not know how to create FTP contact with your hosting provider, they will help you.

    Regards

    Avatar: Lemontronik
    Lemontronik
    Participant
    April 19, 2021 at 02:08

    Hi guys, I think I am experiencing problems with the Spanish translation beyond what I had mentioned in the previous comment; Until the moment I contacted you, everything was fine, I just couldn’t translate some strings of words on the subject; But now that I wanted to check some things, I realize that the store page in the Spanish version does not load the products, it simply loads blank. It is important for me to solve this as soon as possible; I appreciate your help

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 22, 2021 at 07:18

    Hello,

    Sorry for the delay in answering.
    We did nothing with the Shop page.
    We can’t connect, please, provide FTP username and port.

    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 22, 2021 at 08:31

    Hello,

    1) If you want to use the Polylang plugin for the WooCommerce you need an additional addon. See the FAQ section: https://wordpress.org/plugins/polylang/#faq
    Did you remove the Polylang WooCommerce plugin?

    2) Problem with transaltion is related to your Locale. You set es_CO https://prnt.sc/11ut6ax but created transltion files for the royal-es_ES. So, it won’t work. Create translation files also for the royal-es_CO.

    Regards

  • Viewing 7 results - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.