Header Havoc: Resolving Design Disruption Inside Xstore Editor

This topic has 14 replies, 3 voices, and was last updated 2 months, 2 weeks ago ago by Luca Rossi

  • Avatar: jo
    jo
    Participant
    April 4, 2024 at 18:13

    Hello,

    The header is displaying oddly, and the design appears disrupted. However, it appears normal inside the Xstor editor.

    Could you please assist me in resolving this issue? Thank you.

    Please, contact administrator
    for this information.
    Files is visible for topic creator and
    support staff only.
    13 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 5, 2024 at 07:46

    Hello,

    Thank you for reaching out to us with your concern regarding the mobile header display issue.

    We suggest that you turn off the Mobile Content Optimization option in (XStore > Theme Options > General) if you are using a cache plugin for mobile devices, as both optimization options can conflict with each other and will not improve the speed together.

    We trust this will resolve your issue. If you have any additional questions or concerns, please do not hesitate to reach out to us. Our support team is always available to assist you.

    Yours sincerely,
    The 8Themes Team

    Avatar: jo
    jo
    Participant
    April 5, 2024 at 08:36

    Hello,

    Thank you for your prompt response.
    Despite turning off the Mobile Content Optimization, the issue persists.

    Could you please verify? I have shared the login details.

    Thank you.

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 5, 2024 at 08:43

    Hello,

    Upon completion of the diagnostic process, it appears that the issue may be attributed to a cached version. We kindly advise you to clear your cache, including the CDN, to resolve the problem.

    Yours sincerely,
    The 8Themes Team

    Avatar: jo
    jo
    Participant
    April 5, 2024 at 09:26

    Hi,

    cleared cache with WP rocket but I don’t have the premium version in order to use RocketCDN.

    In cloudflare for CDN I have two options:
    1. Custom purge
    2. Purge everything

    I tried custom purge only on the main domain but nothing changed. Cloudflare strongly recommends using single-file (by URL) purging instead of a complete cache purge.

    Should I go for purge everything?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 5, 2024 at 10:56

    Hello,

    We are not sure about your settings for cache and CDN, so we would recommend you to disable both and check the result.
    Should this action resolve the issue, we recommend reaching out to the support team of your cache plugin or/and Cloudflare CDN for additional guidance and assistance.

    Yours sincerely,
    The 8Themes Team

    Avatar: jo
    jo
    Participant
    April 5, 2024 at 14:41

    Hello,

    I’ve cleared the cache and CDN, but the issues persist. Additionally, I’ve edited a new header, yet the problem remains unchanged.

    Could you please investigate this technical issue further and provide a solution?

    Thank you

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 5, 2024 at 14:46

    Hello,

    There is no problem when you log in as admin, because cache does affect the site in this case. The issue is visible for unlogged customers. Please do what we asked you, disable caching at all, including CDN, and check then.

    Thank you for your cooperation.

    Yours sincerely,
    The 8Themes Team

    Avatar: jo
    jo
    Participant
    April 5, 2024 at 15:13

    Hi,

    followed your instructions and disabled caching and CDN.
    Still I see the disrupt header.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 5, 2024 at 15:28

    Hello,

    Could you please provide FTP access?
    For FTP access, we require the following details: FTP host, FTP username, FTP password, FTP port, and FTP encryption type. If you need assistance in creating these credentials, please reach out to your hosting provider who will guide you through the process.

    Best Regards,
    8Theme’s Team

    Avatar: jo
    jo
    Participant
    April 5, 2024 at 16:34

    Hi,

    here the details

    Thanks

    Please contact administrator
    for this information.
    Avatar: Justin
    Luca Rossi
    Support staff
    April 6, 2024 at 12:49

    Hi @jo,

    We hope this message finds you well.

    We have recently observed that the “Remove Unused CSS” feature inadvertently eliminated the custom CSS codes specific to the mobile header. To address this issue, we have added the “.mobile-header-wrapper” CSS class to the whitelist, which has resolved the problem.

    For your reference, here is a screenshot demonstrating the successful implementation of the changes: https://prnt.sc/71QMPAOU5yAe

    We kindly request that you clear the cache on your end to ensure that these updates are fully applied and visible.

    We appreciate your prompt attention to this matter and look forward to your confirmation that the changes have been successfully reflected on your side.

    Thank you for your cooperation.

    Best Regards,
    The 8Theme Team

    Avatar: jo
    jo
    Participant
    April 6, 2024 at 13:14

    Hi Luca,

    Great news! I’ve cleared the cache, and everything appears to be working perfectly now.

    Thank you for your patience.

    Best regards

    Avatar: Justin
    Luca Rossi
    Support staff
    April 6, 2024 at 15:47

    Dear @jo,

    We are pleased to learn that all is functioning properly at this time.

    Warm regards,

    The 8Theme Team

  • Viewing 14 results - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.