Google Search Console Indexing Unncessary Pages/Theme Elements

This topic has 4 replies, 2 voices, and was last updated 1 years, 7 months ago ago by Tony Rodriguez

  • Avatar: slippery
    slippery
    Participant
    November 30, 2022 at 10:34

    Hello, I recently noticed that 80-90% of the pages being crawled by Google Search Console are unncessary pages or theme elements that shouldn’t be crawled.

    I have included a screenshot as private content.

    Is there a way to address this without manually adding each of the 200+ pages to the noindex list.

    Additionally, some of my permalinks didn’t change correctly. I am trying to redirect the folllowing link:

    https://mysite.com/OLDPATH/articlename/

    to

    https://mysite.com/NEWPATH/articlename/

    so that it takes effect everywhere but I am unable to do so. I tried “(.*)” and “1$” parameter but it did not preserve the final part of the link.

    Any help on this would be greatly appreciated as well.

    Please, contact administrator
    for this information.
    3 Answers
    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    November 30, 2022 at 13:34

    Hello, @slippery,

    Our theme does not have any limits for indexing.

    You can check this article: https://www.voog.com/blog/how-to-remove-your-website-or-web-page-from-google

    So, read this post https://www.curiousants.com/game-plan/technical-seo/google-search-console-coverage-excluded/ and check if you have anything of that.

    Also, we would recommend creating the correct robots.txt file and trying to force index some pages.

    OR you can use the Yoast SEO plugin, it is fully compatible with our theme and it is the best one for the SEO of the WordPress site.

    Regards 8Themes Team.

    Avatar: slippery
    slippery
    Participant
    December 2, 2022 at 12:09

    Hi @Tony_Rodriguez, thank you for sharing those links but my problem isn’t that Google isn’t or is indexing my actual WordPress page.

    It is indexing things like https://mysite.com/shop/?view_mode=list and https://mysite.com/category/productname/?sale_status=1

    I haven’t seen this happen with other sites, WordPress or otherwise, and I suspect this isn’t ideal for SEO.

    The links you shared do not contain information about my specific issue and my robots.txt already contains the right pages and tags.

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    December 3, 2022 at 07:17

    Hello, @slippery,

    Our theme has the option to set the noindex on URLs. Simply navigate to the Dashboard >> XSTORE >> Theme Settings >> General/Layout >> see the image: https://postimg.cc/XZPnZtbr theme has only this option nothing else. Further, all the indexing and SEO settings are managed by the SEO plugins. So regarding the crawled pages if the option of the theme I showed you do not work for you then you have to check the SEO plugin settings or forward to the address them manually.

    Just want to mention that the links you shared with us are not opening as you can see in this image: https://postimg.cc/rdqLDc3y

    You can try with the Yoast SEO plugin as well.

    Regards 8Themes Team.

  • Viewing 4 results - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.