Filter Brand - by Web Admin - on WordPress WooCommerce support

This topic has 18 replies, 3 voices, and was last updated 2 years, 6 months ago ago by Rose Tyler

  • Avatar: jonathan
    Web Admin
    Participant
    November 8, 2021 at 00:42

    Hi Team,

    We have noticed that our Brand Filter is not working properly. For example when we filter our shop by price and then we try to filter again by brand, all the brands are still selectable it hasn’t filtered the brands out by price.

    It can be seen here on our ‘New Products’ page – https://bla.com.au/product-category/new-products/

    If trying to filter by brand it lists all the brands not just the ‘New Product’ brands. And then if you choose a brand it filters the whole catalogue not the ‘New Products’ page.

    How can we fix this?

    17 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 8, 2021 at 09:30

    Hello,

    Provide temporary wp-admin and FTP aceess, so we can take a closer look.

    Regards

    Avatar: jonathan
    Web Admin
    Participant
    November 8, 2021 at 23:42

    Ok I’ve provided those for you.

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 9, 2021 at 16:46

    Hello,

    Please check FTP access, we can’t connect.
    You are using 8theme – Brand List, but it should be 8theme – Filter Products by Brands https://prnt.sc/1ywfqh5 , then all will work fine. However, this widget doesn’t have the ability to be displayed as a dropdown. Provide correct FTP access, or wait for the next theme update to get the dropdown displaying for the 8theme – Filter Products by Brands widget.

    Regards

    Avatar: jonathan
    Web Admin
    Participant
    November 10, 2021 at 02:34

    Hi Rose,

    Thanks for clarifying that up.

    The logins provided are the correct ones. Please check the link i’ve sent you.

    Also we noticed now that there are menus appearing in the footer area of our site. I have tried disabling them through theme options and the widget area however can’t find the button to do so. https://bla.com.au/wp-content/uploads/2021/11/Screen-Shot-2021-11-10-at-11.28.38-am.png

    How can we fix this also?

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 10, 2021 at 07:47

    Hello,

    1/ We can’t connect

    Error: Connection timed out after 20 seconds of inactivity
    Error: Could not connect to server

    Do you have any limits for connections from other countries?
    What FTP port should be used?
    2/ Appearance > Widgets > check content of PreFooter and Footer areas

    Regards

    Avatar: jonathan
    Web Admin
    Participant
    November 15, 2021 at 00:06

    Hi,

    Thanks for the widgets fix.

    Not sure why FTP isn’t working. We have supplied the same details as all our previous tickets.

    Do you have a estimate when the next update will be pushed?

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 15, 2021 at 13:10

    Hello,

    Got it. I passed issue to developers. I’ll inform you once they implement this feature on your site.

    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 15, 2021 at 15:46

    Hello,

    Check now, please.

    Regards

    Avatar: jonathan
    Web Admin
    Participant
    November 15, 2021 at 23:50

    Hello,

    Thank you! It’s perfect.

    Can you please supply me the code so I can implement it on our other site bla.co.nz?

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 16, 2021 at 18:39

    Hello,

    Copy the theme folder and XStore Core plugin folder from that site to bla.co.nz.

    Regards

    Avatar: jonathan
    Web Admin
    Participant
    November 17, 2021 at 02:12

    Hello,

    Thanks I followed your instructions. It works however it is a little buggy. I tested it again on bla.com.au. We notice that when filtering by brand it doesn’t filter the prices as well. For example if we are on the shop page and we filter by brand it will filter down by brand however the price range remains the lowest and highest price for the entire shop not just the brand. As you can see here https://bla.com.au/wp-content/uploads/2021/11/Screen-Shot-2021-11-17-at-10.57.17-am.png

    However it does work normally when filtering by category. Although we also notice that there’s a bug when filtering by category > Anchor Winches https://bla.com.au/wp-content/uploads/2021/11/Screen-Shot-2021-11-17-at-10.57.44-am.png

    The price filter disappears. How can we fix these?

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 17, 2021 at 18:02

    Hello,

    Passed that issue to developers. I’ll inform you once they fix.

    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 22, 2021 at 13:15

    Hello,

    Check now, please.

    Regards

    Avatar: jonathan
    Web Admin
    Participant
    November 23, 2021 at 00:13

    Hello,

    Thanks for the fix it is working great! Brand filter and Pricing filter are working together. However know we noticed now that the Brand filter & Category filter aren’t working together. For example if we’re on the shop page again and we Filter by Brand it doesn’t filter only the categories related to that brand, it will show all categories.

    How can we fix this?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 23, 2021 at 13:36

    Hello,

    You’re welcome!
    The categories widget is not a filter. Neither WooCommerce nor our theme has filter by categories, there is only the categories list widget. If you need a filter widget you need to look for third-party filer plugins. Please note that we do not give a guaranty for full theme compatibility with all existing 3rd party plugins.

    Regards

    Avatar: jonathan
    Web Admin
    Participant
    November 25, 2021 at 01:39

    Ok no worries.

    Thanks for your support!

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 25, 2021 at 07:58

    You’re welcome!

    Regards

  • Viewing 18 results - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.