Desktop Header and Mobile Header are not separated

This topic has 5 replies, 2 voices, and was last updated 1 months ago ago by Rose Tyler

  • Avatar: MarkChatters
    MarkChatters
    Participant
    June 23, 2024 at 21:31

    Hello! I’m trying to have different mobile and desktop headers. They are distinctly different in the Xstore header builder, but when I actually publish them, they are either 1 or the other.

    Example, if Iw as last editing my desktop header, publish it, the desktop header will appear on both mobile and desktop. If I was last editing my mobile header then publish it, the mobile header appears on both desktop and mobile. It seems to be whichever one I last published even though they are distinctly different in the builder.

    If you go to the site on mobile then on desktop you can see. It seems like just in general, the site isn’t respecting whether the header is mobile or desktop and just chooses one as it pleases.

    I got it to work a while ago, and without touching it, it seems to revert itself all the time. It’s a tad frustrating so any help would be awesome 🙂

    Please, contact administrator
    for this information.
    4 Answers
    Avatar: MarkChatters
    MarkChatters
    Participant
    June 23, 2024 at 21:40

    Here is what the mobile version should look like on mobile

    Files is visible for topic creator and
    support staff only.
    Avatar: MarkChatters
    MarkChatters
    Participant
    June 23, 2024 at 21:41

    Here is what the desktop should look like

    Files is visible for topic creator and
    support staff only.
    Avatar: MarkChatters
    MarkChatters
    Participant
    June 23, 2024 at 23:29

    Edit:

    I turned off mobile optimization and that seems to have potentially fixed the issue. But, what exactly does mobile optimization do besides just that? I just want to make sure I’m not breaking anything else or hurting my sites speed. Thanks!!

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    June 24, 2024 at 08:09

    Hello MarkChatters,

    Thank you for contacting us and for using XStore.

    https://prnt.sc/ox3wwdgBs69N
    You are using a cache plugin for mobile devices, and both optimization options (plugin and theme options) conflict with each other and can not improve the speed together. Disabling mobile optimization via Theme Options is correct in your case.

    Kind Regards,
    8theme team

  • Viewing 5 results - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.