Xstore theme – issue with product thumbnails

This topic has 34 replies, 4 voices, and was last updated 3 years, 10 months ago ago by Olga Barlow

  • Avatar: G
    R
    Participant
    July 16, 2020 at 20:13

    Hello Support team,

    I am getting an issue with products images.

    When seeing products, they don’t seem to come up with their smaller, thumbnail versions, but full sizes.

    Can you please help to fix this issue?

    Here’s what I’ve done so far:

    1. Reviewed similar posts on this forum, like https://www.8theme.com/topic/how-to-make-gallery-images-as-thumbnails-on-single-product-page/

    But their solution don’t work for me.

    2. Looked into the code, wp-content/themes/xstore/framework/woo.php : 1047 : function etheme_lazy_swiper_image

    But to no avail.

    Thanks!

    Please, contact administrator
    for this information.
    33 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    July 17, 2020 at 06:56

    Hello,

    Please read this article https://xstore.helpscoutdocs.com/article/89-product-images , set the desired size > regenerate thumbnails.

    Regards

    Avatar: G
    R
    Participant
    July 19, 2020 at 21:43

    Hello Rose,
    Thank you for replying.
    I did that, multiple times, but to no good result.
    Can you please login to my WordPress admin panel and see?

    Thanks!

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    July 20, 2020 at 10:38

    Hello,

    On which page you can see this situation?
    If products are shown via element, check settings of Image size – http://prntscr.com/tl46yw
    Here what I can see – http://prntscr.com/tl484m Clear cache and check one more time.

    Regards

    Avatar: G
    R
    Participant
    July 25, 2020 at 01:08

    I’m still having issues. Please have a look. On the home page slider the images all look blurry but when you click on the product or on shop page grid, they look good/clear…? This is very frustrating.

    Please contact administrator
    for this information.
    Avatar: John Holden
    John Holden
    Support staff
    July 25, 2020 at 05:40

    Hi,

    Please provide temporary wp-admin and FTP access, so we can take a closer look

    Regards,
    Hung PD

    Avatar: G
    R
    Participant
    July 26, 2020 at 17:15

    OK:

    Please contact administrator
    for this information.
    Avatar: G
    R
    Participant
    July 26, 2020 at 17:24

    Another issue with images: Mobile functions are off as Images are missing on mobile but showing on desktop and watermarks on images are showing on desktop but not mobile.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    July 27, 2020 at 17:57

    Hello,

    I see that you have the below code http://prntscr.com/tpf12m for the images on the home page

    #category-image a.product-content-image img {
        height: 300px!important;
        object-fit: cover!important;
        width: 300px!important;
    }

    Try to remove it and check after that.

    Regards

    Avatar: G
    R
    Participant
    August 12, 2020 at 03:13

    Can you please tell me how to remove that? I’m not sure how that happened. Also, I just want my images to look good on homepage, and shop page, please help me fix this.

    Avatar: John Holden
    John Holden
    Support staff
    August 12, 2020 at 05:09

    Hi,

    It comes from Xstore child theme

    Regards,
    Hung PD

    Avatar: G
    R
    Participant
    August 12, 2020 at 18:32

    I overstand but there are two xstore theme options in my store, can you have a look?

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 13, 2020 at 11:52

    Hello,

    We’ll fix it in the next 7.0 update.

    Regards

    Avatar: G
    R
    Participant
    August 18, 2020 at 23:34

    I see two themes, xstore and xstore child. Which one am I suppose to activate?? Did you fix it??

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 19, 2020 at 12:15

    Hello,

    You should use XStore child. Read more what the child theme is here https://developer.wordpress.org/themes/advanced-topics/child-themes/

    We’ll fix double options in the 7.0 of XStore theme update. 7.0 update coming soon.

    Regards

    Avatar: G
    R
    Participant
    August 19, 2020 at 22:12

    You’ll fix what in 7.0? I’m so confused. I’ve been asking about the same thing over & over again for weeks now and my issue still has not been resolved by your support!

    Avatar: John Holden
    John Holden
    Support staff
    August 20, 2020 at 06:04

    Hi,

    We fixed 2 Theme Options in dashboard. Please update theme & Xstore core plugin to latest version.

    Regards,
    Hung PD

    Avatar: G
    R
    Participant
    August 24, 2020 at 17:20

    There is a major issue with xstore child theme. When I use that theme my header and footer info is missing. When I activate xstore theme (not child) my content is showing but my pop up forms are messed up.

    Also why is there 2 Theme Options showing still??

    Please contact administrator
    for this information.
    Avatar: G
    R
    Participant
    August 26, 2020 at 00:18

    OMG!! PLEASE HELPPPP!!! IT’S BEEN OVER 30+ HRS HOURS!!!

    Avatar: John Holden
    John Holden
    Support staff
    August 26, 2020 at 05:31

    Hi,

    I’m so sorry for the delay that you faced.

    Check now please

    Regards,
    Hung PD

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 26, 2020 at 11:18

    Hello,

    Take into account that when you switching themes widgets could be messed up that’s why after switching you need to go to Appearance > Widgets > and place them to correct areas.

    Also, child theme inherits parent theme styles but it does not inherit theme options, so if you want to switch theme just for testing purposes then just ignore the missing header but if you want to switch to other theme on regular basis then don’t forget to Export theme settings before switching (Theme Options > Export/Import ) and import them after switching.

    Regards

    Avatar: G
    R
    Participant
    August 26, 2020 at 14:59

    My footer is still not looking right. (You can look at xstore paren theme to compare) Half of my footer content is still missing; quick link tabs, content for charity grace period, there is an additional footer line with Created by Power Elite Themeforest Author that I did not add! Also on mobile app my logo is missing, and the footer content is missing.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 26, 2020 at 17:34

    Hello,

    Take into account that when you switching themes widgets could be messed up that’s why after switching you need to go to Appearance > Widgets > and place them to correct areas.

    Regards

    Avatar: G
    R
    Participant
    August 27, 2020 at 16:21

    When I go and look at theme options it’s showing in the left side of the bar but not showing on actual website:
    This is for header, Contact Us & Also Footer area content:

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 27, 2020 at 16:54

    Hello,

    Because footer color scheme is dark in your footer settings http://prntscr.com/u6ym70 It means dark text on dark bg. I have changed it to Light. Check now.

    Regards

    Avatar: G
    R
    Participant
    August 27, 2020 at 17:38

    What about the header? Contact us is not showing

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 28, 2020 at 13:34

    Hello,

    Provide us with screenshot where it should be. Because I don’t remember your header in detail.

    Regards

    Avatar: G
    R
    Participant
    August 28, 2020 at 15:50

    Hi Olga, I fixed the contact on the header myself, but can you answer my original question on this post? You said:
    Hello,

    I see that you have the below code http://prntscr.com/tpf12m for the images on the home page

    #category-image a.product-content-image img {
    height: 300px!important;
    object-fit: cover!important;
    width: 300px!important;
    }
    Try to remove it and check after that.

    Regards

    #245607

    -Were you able to see if this has been fixed or removed? I really need my shop images to be clear. This is a huge issue for me as it makes or breaks the sales on my website. As you can see the product images look blurry until you click on them, then the single product page images look clear. Thank you!

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 28, 2020 at 17:43

    Hello,

    That code was removed from your child theme a few days ago.
    We don’t have solution for your images, sorry.

    Regards

    Avatar: G
    R
    Participant
    August 28, 2020 at 23:44

    Can I ask you what do you think is the issue? How come the images look blurry only home page, but not on shop page or single product page? On those two pages they look clear. This is so strange 🙁

  • 1 2
    Viewing 30 results - 1 through 30 (of 34 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.