WooCommerce Email Builder – WP sends system standard template not from the builder

This topic has 6 replies, 2 voices, and was last updated 1 years, 2 months ago ago by Tony Rodriguez

  • Avatar: miki
    miki
    Participant
    January 20, 2023 at 23:33

    Hi, When new order comes, customer get and standard wooCommerce email template, not the new one that I build by the WooCommerce Builder.

    When new customer creates his account – system sends correct template – from the builder.

    I cant figure it out how it works? Pls help 🙂
    I want to use only EmailBuilder versions.

    Please, contact administrator
    for this information.
    5 Answers
    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    January 21, 2023 at 06:53

    Hello @miki,

    I recently ordered an item from your site to test the new order email layout, and the result can be seen here: https://postimg.cc/Js12shKX.

    I then edited the email layout for the new order you created, and set the condition of the layout to “On Hold”. The order I created on your site was not on hold, so I edited the order and set the status of the order to “On Hold”. You can see the result here: https://postimg.cc/yJrQr49r.

    After saving the settings, I received a new email with the layout you created, which can be seen here: https://postimg.cc/18vJfhW5. As you can see, it is now working correctly.

    Best Regards,
    8Theme’s Team

    Avatar: miki
    miki
    Participant
    January 21, 2023 at 08:08

    Hi!
    Yes I have the same situation in my test order.

    My question is why the first email that is sent to the customer is ps://postimg.cc/Js12shKX instead of this: https://imgur.com/a/5SunF5y

    My screenshot contains the correct message for customer that order has been placed correctly.

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    January 21, 2023 at 09:16

    Hello @miki,

    By default, WooCommerce sets the status of a new order to “Processing” instead of “On Hold,” and the layout of the new order created using the Email Builder feature of our theme will only work with the “On Hold” product status. Therefore, “Processing” and “On Hold” are two distinct statuses.

    Unfortunately, there are no settings in WooCommerce or in the theme to make the new order status “On Hold” by default.

    However, I have found an article that may be of assistance. Please review the article carefully to understand the order system and make any necessary changes: https://webappick.com/how-to-change-default-order-status-in-woocommerce/.

    Best Regards,
    8Theme’s Team

    Avatar: miki
    miki
    Participant
    January 21, 2023 at 10:14

    Tony, so you suggest to change default status after accepted payment from PROCESSING to ON HOLD? By changing that in fuctions.php WooCommerce will sent correct email from the Builder?

    Does it affect in some other shop functionality?

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    January 23, 2023 at 09:48

    Hello @miki,

    Exactly, you need to update the status of the order so that the email layout you have created is sent correctly. We do not anticipate any issues with the code affecting the other shop functions.

    Best Regards,
    8Theme’s Team

  • Viewing 6 results - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.