Very big problem with variable product creation

This topic has 16 replies, 3 voices, and was last updated 2 years, 2 months ago ago by Olga Barlow

  • Avatar: franci64
    franci64
    Participant
    November 15, 2021 at 08:44

    Dear Sirs after updating XStore plugin to v. 4.09 and the theme core to 8.09 version we have problem with variable product creation. It is not possible to create variations after the setting of attributes. Here a link to test this issue

    https://www.cagnolinofelice.it/wp-admin/post.php?post=8202&action=edit

    Please, contact administrator
    for this information.
    15 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 15, 2021 at 09:12

    Hello,

    BE ATTENTIVE and don’t place the private information in the general message area because all the visitors have access to that information. Use the Private Content area.

    As I can see, variations were created for the mentioned product – https://gyazo.com/c422a0947f2f5006dd50df6ad1c5af21 Could you record a video of the problem?

    Regards

    Avatar: franci64
    franci64
    Participant
    November 15, 2021 at 09:39

    You should check the code for the color and size variants if everything is ok. The product https://www.cagnolinofelice.it/prodotto/relax-cuccia-pelosetta-antistress/ is currently working but yesterday I changed a photo and the url was changed and the colors and sizes disappeared. your theme code does not conflict with Woocommerce ?? Also there is an update of Woocommerce and Woocommerce Paypment that I don’t know if I can do given these problems of little compatibility with your theme

    I also need to install a plugin for the bundles, do you have a recommended plugin to install with your theme ??

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 15, 2021 at 14:09

    Hello,

    I suppose that issue could be caused by the CDN cache that you use. So, clear CDN cache after updates. All the updates available for plugins you can find under Dashboard > Updates.

    We don’t have any special recommendations for the bundles. If you install any and face compatibility issues just contact us.

    Regards

    Avatar: franci64
    franci64
    Participant
    November 17, 2021 at 18:10

    Private message

    Please contact administrator
    for this information.
    Avatar: franci64
    franci64
    Participant
    November 17, 2021 at 18:22

    The problem encountered is in the Permalink.
    If I duplicate a product and go to make some changes to the duplicate product sometimes I skip everything and automatically change the permalink as duplicate permalink name-2 and lose all settings. I have my online shop ready and with people waiting to order but can’t order because it doesn’t work, I hope you can help me quickly 🙁

    https://www.cagnolinofelice.it/prodotto/relax-cuccia-pelosetta-antistress/
    This is the product page crashed
    It had many color variations and sizes and they all got lost 🙁

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 18, 2021 at 14:09

    Hello,

    Our theme should not cause any issues with the product attributes or variations. I suppose that you updated not just theme but also WooCommerce plugin. Besides, I see that you have some plugin for the DB optimization.

    Could you, please, create staging site (full copy of the existing) and test if you have the mentioned issue if any other theme is enabled? Storefront for example. Let me know about the results.

    Regards

    Avatar: franci64
    franci64
    Participant
    December 17, 2021 at 00:37

    Hi Olga, I tried to change the theme and the size and color variants with another theme that works, so the problem is with your theme or the integration with Woocommerce or Elementor. Now I tried to create a new product from scratch called LUX unifier cada led 2 and as soon as I save it in the Permalink, “show-3” appears, which is the permalink of the first article created with the addition of 3. also if I open the products does not show me the sizes and colors that I created in this article but shows me those of the showy product, I’m going crazy please help me !!!

    Access to my site to verify in private content area please

    I await your feedback and I hope that you will solve this huge problem for me as soon as possible. Thanks Enrico

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 17, 2021 at 15:44

    Hello,

    Provide us with FTP access to your site, please. We’ll check the issue in more detail.

    Regards

    Avatar: franci64
    franci64
    Participant
    December 17, 2021 at 16:28

    Ok, privately I sent the requested FTP data. I await your reply as soon as possible as I need to go back online with my store. Thanks Enrico

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 20, 2021 at 10:09

    Hello,

    Could you, please, provide us with video of the issue? Because I tried to duplicate the mentioned product and then edit the permalinks of this product and variations are the same. So, we need to check your actions to reproduce the issue and help you.
    You can use the Recordit tool to make and share video.

    Regards

    Avatar: franci64
    franci64
    Participant
    December 20, 2021 at 10:29

    Hi Olga, to see the problem at this point try to modify the variants of the duplicate product by putting different variants compared to the original product. At this point, if you have changed the permalink and the variants when you save product and exit, the product variants skip and those of the original product are restored. Try this and let me know

    Avatar: franci64
    franci64
    Participant
    December 20, 2021 at 10:37

    also today we received this email from WordPress about an error on your plugin, I don’t know if it could be due to this, I am attaching the email

    Ciao!

    WordPress, a partire dalla versione 5.2, ha una funzionalità integrata che rileva quando un plugin o un tema provoca un errore irreversibile sul tuo sito e ti avvisa con questa email automatica.

    In questo caso, WordPress ha incontrato un errore con uno dei tuoi plugin, XStore Core.

    Per prima cosa, vai al tuo sito web (https://www.vivereallagrande.com/) e controlla se ci sono problemi visibili. Successivamente, vai nella pagina in cui è stato rilevato l’errore (https://www.vivereallagrande.com/wp-admin/post.php?post=8596&action=edit) e verifica se c’è qualche problema visibile.

    Contatta il tuo host per richiedere assistenza per una investigazione più approfondita di questo problema.

    Se il tuo sito appare danneggiato e non puoi accedere normalmente alla tua bacheca, WordPress ora ha una speciale “modalità di ripristino”. Ciò ti consente di accedere in modo sicuro alla tua bacheca per controllare cosa non va.

    https://www.vivereallagrande.com/wp-login.php?action=enter_recovery_mode&rm_token=mdOSpPW14fD6dGMd631JTg&rm_key=HvG8JbKbaQAnigOG49gD57

    Per mantenere il tuo sito sicuro, questo link scadrà tra 1 giorno. Non preoccuparti di questo: ti verrà inviato un nuovo link se l’errore si ripresenta dopo la scadenza.

    Se cerchi aiuto per questo problema, ti potrebbero essere chieste alcune delle seguenti informazioni:
    Versione di WordPress 5.8.2
    Tema corrente: Storefront (versione 3.9.1)
    Plugin corrente: XStore Core (versione 4.0.11)
    Versione PHP 7.4.26

    Dettagli dell’errore
    ====================
    Un errore di E_ERROR è stato causato nella linea 125 del file /home/customer/www/vivereallagrande.com/public_html/wp-content/plugins/et-core-plugin/app/controllers/elementor.php. Messaggio di errore: Uncaught Error: Call to undefined function ETC\App\Controllers\etheme_get_option() in /home/customer/www/vivereallagrande.com/public_html/wp-content/plugins/et-core-plugin/app/controllers/elementor.php:125
    Stack trace:
    #0 /home/customer/www/vivereallagrande.com/public_html/wp-includes/class-wp-hook.php(303): ETC\App\Controllers\Elementor->enqueue_studio(”)
    #1 /home/customer/www/vivereallagrande.com/public_html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
    #2 /home/customer/www/vivereallagrande.com/public_html/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
    #3 /home/customer/www/vivereallagrande.com/public_html/wp-settings.php(578): do_action(‘init’)
    #4 /home/customer/www/vivereallagrande.com/public_html/wp-config.php(90): require_once(‘/home/customer/…’)
    #5 /home/customer/www/vivereallagrande.com/public_html/wp-load.php(50): require_once(‘/home/customer/…’)
    #6 /home/customer/www/vivereallagrande.com/public_html/wp-admin/admin.php(34): require_once(‘/home/customer/…’)
    #7

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 20, 2021 at 15:41

    Hello,

    I tested your product and duplicated that, changed variations and did not face problem https://recordit.co/P61IillrsW
    So, What exactly is wrong? Make a video, please.

    Regards

    Avatar: franci64
    franci64
    Participant
    December 20, 2021 at 16:02

    Hi Olga, I am sending you privately the link of the video where I show you the problem. In practice, in the first 4 minutes I create the new product with its variants, I publish it and everything seems ok. After minute 4 I return to the product, change a photo and automatically change the Permalink to showy-4 and if I open the article on the site as you see the colors and sizes, it restores those of the original product we copied. Now is the problem clear?

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    December 21, 2021 at 15:20

    Hello,

    I have enabled the default WooCommerce theme Storefront and faced the same issue https://recordit.co/N8zsxVWCF5
    So, our theme is not the reason of the problem. Contact WooCommerce plugin support.
    Besides, I see that you have third-party plugin for the Database, maybe that caused the problem, not sure.

    We can help you with nothing with that if the problem appears even with the default theme.

    Regards

  • Viewing 16 results - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.