Updated theme now have all kinds of errors

This topic has 4 replies, 2 voices, and was last updated 3 years, 10 months ago ago by Olga Barlow

  • Avatar: 2nd Line MArketing
    2nd Line MArketing
    Participant
    July 29, 2020 at 00:22

    Hello I updated a site and purchased the theme to update it as original purchase code is MIA. Anyway I can no longer use several plugins (woo commerce dynamic pricing) and I am getting errors when I try to run setup etc.

    Deprecated: get_currentuserinfo is deprecated since version 4.5.0! Use wp_get_current_user() instead. in /home/stayfire2020/public_html/wp-includes/functions.php on line 4713

    Notice: Trying to get property ‘base’ of non-object in /home/stayfire2020/public_html/wp-content/plugins/Ultimate_VC_Addons/modules/ultimate_tab.php on line 1333

    Notice: get_current_page was called incorrectly. Current page retrieval should be called on or after the current_screen hook. Please see Debugging in WordPress for more information. (This message was added in version 0.16.0.) in /home/stayfire2020/public_html/wp-includes/functions.php on line 5167

    Notice: get_current_page was called incorrectly. Current page retrieval should be called on or after the current_screen hook. Please see Debugging in WordPress for more information. (This message was added in version 0.16.0.) in /home/stayfire2020/public_html/wp-includes/functions.php on line 5167

    3 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    July 29, 2020 at 11:44

    Hello,

    1) We don’t use get_currentuserinfo in our theme, so this notice does no come from our theme or core plugin.
    2) What version of Ultimate_VC_Addons plugin do you use? And dod you use Ultimate_VC_Addons plugin elemenets on your site or just keep the plugin enabled just in case?
    3) Go to Appearance > Themes > install and activate the Storefront theme. Test if WooCommerce dynamic pricing plugin works fine when the official WooCommerce theme is enabled. If not then contact plugin author.

    Regards

    Avatar: 2nd Line MArketing
    2nd Line MArketing
    Participant
    July 29, 2020 at 18:47

    Your theme (WooPress Child) contains outdated copies of some WooCommerce template files. These files may need updating to ensure they are compatible with the current version of WooCommerce. Suggestions to fix this:

    Update your theme to the latest version. If no update is available contact your theme author asking about compatibility with the current WooCommerce version.
    If you copied over a template file to change something, then you will need to copy the new version of the template and apply your changes again.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    July 30, 2020 at 16:17

    Hello,

    Provide us with WP Dashboard and FTP access to your site to check our theme files and what files you copied to child theme. Did you make any changes in child theme? If yes then probably child theme files should be updated according to the latest changes in the parent theme.

    Regards

  • Viewing 4 results - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.