Theme Update Error - by DebbieC - on WordPress WooCommerce support

This topic has 14 replies, 4 voices, and was last updated 3 years ago ago by Olga Barlow

  • Avatar: DebbieC
    DebbieC
    Participant
    February 3, 2021 at 10:43

    I done my recent updates on my staging site which now has theme version 7.2.4 & core version 3.2.4, that updated okay. However 2 days later I tried to update the live site to version 7.2.4 but Xstore Core update gives me an error – Update failed: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    When I click on ‘details’ it says Plugin not found. Do you know what would cause this error as I need to be able to update?

    Please, contact administrator
    for this information.
    13 Answers
    Avatar: Robert Hall
    Robert Hall
    Support staff
    February 3, 2021 at 11:03

    Hi

    Thank you so much for contact us !

    There are a number of reasons that an automatic update could fail. It is a large plugin, with many modules and files. This can cause issues with some servers when using the automatic update.

    Could you please try manually reinstalling this plugin ?

    Avatar: DebbieC
    DebbieC
    Participant
    February 3, 2021 at 11:32

    I don’t know how to reinstall it manually, I have always done it using the update now button. If it is manual, does it overwrite the child theme or anything?

    Avatar: Robert Hall
    Robert Hall
    Support staff
    February 3, 2021 at 11:38

    Hi

    Please let me know Is your are facing issue in installing theme or Xstore Core Plugin…. ?

    Also check your wordpress , hosting server requirements by going to Dashboard > XStore > Server Requirements

    Avatar: DebbieC
    DebbieC
    Participant
    February 3, 2021 at 11:58

    I always update the Xstore Core Plugin before the theme. I have not attempted to update the theme without the Core Plugin. It worked fine 2 days previously on the Staging site which is on the same server and I have never had this problem before.

    All the elements in system requirements are ticked so I don’t think there is a problem there.

    Avatar: Robert Hall
    Robert Hall
    Support staff
    February 3, 2021 at 12:14

    Try to (1) deactivate theme in XStore > Dashboard and activate it again using your purchase code. (2) After that you need to go to WP Dashboard > Updates > press “check updates” link to force check and clear cached links and only after that try to (3) update theme and XStore core plugin.

    OR update the theme via FTP – https://xstore.helpscoutdocs.com/article/63-theme-update
    https://xstore.helpscoutdocs.com/article/37-plugins-update

    Avatar: DebbieC
    DebbieC
    Participant
    February 3, 2021 at 16:37

    My ‘active’ theme is Xstore Child, not the main Xstore Theme so I cannot de-activate it and re-activate it.

    I also am not sure about the instructions for FTP, do both the XCore and the theme files get uploaded to the /wp-content/plugins/ directory? This won’t overwrite my child theme?

    I need to get this sorted as soon as possible because I am worried I may have to use a backup from days ago and each day I will lose customer details so cannot leave it too many days.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    February 3, 2021 at 21:14

    Hello DebbieC,

    Please provide temporary wp-admin and FTP access, we will help you with the update.

    For the future, never update the Core plugin before the theme update.
    You need to do the update of the parent theme only, as described in our documentation. Files of the child theme need to be touched after the update only in case you rewrited parent theme files via the child theme.
    Deactivation that was mentioned https://prnt.sc/y6iw3r is here – https://prnt.sc/y6iz1w , doesn’t matter parent or child theme.
    Also, here are the correct folders – https://prnt.sc/y6j4sk https://prnt.sc/y6j6jb

    Regards

    Avatar: DebbieC
    DebbieC
    Participant
    February 4, 2021 at 10:38

    HI,

    Thank you. Please find attached login details.

    Debbie

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    February 4, 2021 at 15:13

    Hello,

    Updated. Please clear cache and check your site.

    Regards

    Avatar: DebbieC
    DebbieC
    Participant
    February 4, 2021 at 17:43

    Hi,

    Thank you very much for doing this for me. I hope the next update does not produce the same problem again.

    I have checked the site, one problem I see seems to be that you cannot click the ‘select options’ button (between ‘quick view & wishlist) on the photos, either the homepage or category pages. It is like the link has gone although I can see that the correct link is there. I see another person on the forum also said this but I think you fixed it for. Could you look at this please on my site? Debbie

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    February 4, 2021 at 17:49

    Hello,

    You’re welcome!
    By email we sent a file that should solve the problem. Have you checked it on your staging site?

    Regards

    Avatar: DebbieC
    DebbieC
    Participant
    February 5, 2021 at 11:02

    Hi,
    New Frontend.js file uploaded and all seems to be fine now. Thanks. Debbie

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    February 5, 2021 at 11:25

    Hello,

    You are welcome.

    Regards

  • Viewing 14 results - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.