Theme builder/editor 500 error instantly

This topic has 5 replies, 3 voices, and was last updated 1 years, 2 months ago ago by Tony Rodriguez

  • Avatar: Normunds
    Normunds
    Participant
    February 22, 2023 at 13:41

    Hello!
    When I trying to edit theme by theme builder, im getting error 500 on the right side of the screen- could you please check that issue?

    https://gyazo.com/9e999c20717a0b687dfa12f7d8144a18

    Environment Requirement System
    WP File System: direct direct
    PHP version: 7.4 7.4.33
    WordPress version: 5.8.2 6.1.1
    Memory limit: 128M 5000M
    Max execution time: min (120-180) 500
    Max input vars: min (1000-2000) 3000
    Upload max filesize: 10M 2048M
    ../Uploads folder: writable writable
    OpenSSL version: 1.0 3.53.1
    GZIP compression: enable enable
    file_get_contents( ): enable enable
    wp_remote_get( ): enable enable
    DOMDocument enable enable

    In private content area I have left temporary admin login credentials

    In logs I see these type of error:

    POST /?customize_changeset_uuid=0935f456-05f4-48ec-91fa-6c595bee9899&customize_theme=xstore-child&customize_messenger_channel=preview-0&customize_autosaved=on HTTP/1.0

    Please, contact administrator
    for this information.
    4 Answers
    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    February 22, 2023 at 18:26

    Hello Normunds,

    We suggest that you contact your hosting provider to get more information about the issue you are experiencing. They should be able to provide guidance and explain what is causing the problem. It is likely that you have reached a server limit.

    If you are receiving a 500 error in the Customizer, we recommend that you contact your hosting support to increase the SubstituteMaxLineLength. This limit is usually the cause of the 500 error in the Customizer.

    Best Regards,
    8Theme’s Team

    Avatar: robert
    robert
    Participant
    March 18, 2023 at 00:01

    Hi, I’m having the same issue; you mentioned we should increase the SubstituteMaxLineLength value, but what should it be increased to?

    Avatar: robert
    robert
    Participant
    March 18, 2023 at 00:13

    I looked in the WHM and there is no such setting?, where do i find the SubstituteMaxLineLength value?

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    March 18, 2023 at 06:15

    Hello, @robert,

    The SubstituteMaxLineLength value is typically used in the Exim mail server configuration rather than the WHM (Web Host Manager) interface.

    To modify the SubstituteMaxLineLength value in Exim, you can follow these steps:

    1. Login to your server via SSH as the root user.

    2. Open the Exim configuration file using a text editor such as vi or nano. The location of the file may vary depending on your server setup, but it is usually located at /etc/exim.conf or /etc/exim/exim.conf.

    3. Search for the line that begins with “substitutes” or “substitute” in the configuration file.

    4. If the line does not exist, add it to the configuration file.

    5. Add the “max_linelength” parameter to the substitutes configuration line, as shown below:

    substitutes:
    driver = plaintext
    max_linelength = 5000

    6. Save the changes to the configuration file and exit the text editor.

    7. Restart the Exim service to apply the changes. You can do this by running the following command:

    service exim restart

    After completing these steps, the SubstituteMaxLineLength value should be set to the value you specified in the Exim configuration file.

    Alternatively, please try to reach out to your hosting provider for further assistance on this matter.

    Kind Regards,
    8Themes Team.

  • Viewing 5 results - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.