The mobile version is not displayed properly.

This topic has 21 replies, 4 voices, and was last updated 3 years, 3 months ago ago by Rose Tyler

  • Avatar: Chris_Shan
    Chris Shan
    Participant
    November 8, 2020 at 14:15

    Please have a look at the mobile version, it’s not displayed properly.
    The desktop version looks just fine.
    Why?

    20 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 8, 2020 at 17:06

    Hello,

    At first sight, I do not see any problem with mobile displaying. Could you, please, provide screenshots? What device and browser do you use? Have you tried to clear cache?

    Regards

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 8, 2020 at 23:03

    1

    2

    Device: iPhone 11(iOS 14.2
    Browser: Safari, Chrome, Edge, Firefox

    Yes, caches cleared.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 9, 2020 at 09:17

    It is the same on our demo – https://xstore.8theme.com/elementor/demos/landing/
    Content is displayed according to setting, go to the edit page to change it depends on your needs on mobile.
    Let us know if you need any further assistance.

    Regards

    Avatar: MichaelB
    MichaelB
    Participant
    November 9, 2020 at 17:41

    I have the same problem too.


    @Rose
    – Is there a solution? It seems like a bug more than anything if on the demo it is wrong too… Please find a solution for now and report it as a bug so the developer can sort it out properly.

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 9, 2020 at 22:49

    Yes, it looks same on the demo (https://xstore.8theme.com/elementor/demos/landing/)

    But it looks great on this demo (https://xstore.8theme.com/demos/landing-watch/)

    There must be something wrong.

    1
    2

    Avatar: MichaelB
    MichaelB
    Participant
    November 9, 2020 at 22:59

    Agreed.

    Hopefully, a fix will be provided for us.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 10, 2020 at 16:12

    Hello,

    Use the Elementor responsive options to edit layout according to your needs https://gyazo.com/7aaa003a748ec8abdc642efd6e1d3901

    Regards

    Avatar: MichaelB
    MichaelB
    Participant
    November 10, 2020 at 16:56

    I will but can you please let the developer team know it is a bug?

    It is clearly a bug as the demo even has the issue.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 10, 2020 at 17:35

    Hello,

    It is not a bug, just the elementor demo version had different settings for mobile view compare to our old wpbakery demo.
    We’ve changed it on the demo. You can do changes, as was mentioned by Olga, or provide URL and temporary wp-admin access, so we can change it on your site too.

    Regards

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 11, 2020 at 07:37

    OK, I will try. Thanks.

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 11, 2020 at 07:54

    Thank you Rose, it worked.

    Another question here.

    1

    As you can see I altered the “Sign In” to “登入” and also removed the LOGO from the Theme Options > Header Builder > Account, and pressed publish.

    2

    But on my iPhone nothing changed at all, why?

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 11, 2020 at 09:02

    1
    2

    Also I changed the shopping Cart to Bag and pressed publish, but on my iPhone it’s still the Shopping Cart, nothing changed at all.

    Where did I miss?

    The theme options seems not working.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 11, 2020 at 10:28

    Hello,

    Theme Options > Header builder > Multiple headers > edit header for the Front page
    Also, watch this video – https://youtu.be/BpeXfzNwkOc

    Regards

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 11, 2020 at 10:53

    OK, I see.
    I’ll try, thanks.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    November 12, 2020 at 09:14

    Hello,

    You are welcome.

    Regards

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 12, 2020 at 12:30

    1
    2

    I would like to change these words into Chinese, how can I do it?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 12, 2020 at 13:18

    Hello,

    It looks like you need to re-save Theme Options (go to Theme options > change any settings click of Publish).
    About trasnaltion, Loco translate > Plugins > XStore Core > New language > Choose a language + Choose a location – System > Start translating.

    Regards

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 15, 2020 at 04:10

    Thanks for the language plug-in recommendation.

    1

    I found there are two “hearts” next to the Add to wishlist.

    How can can fix this problem? There should be just one heart.

    ============================================
    SOLVED!

    Avatar: Chris_Shan
    Chris Shan
    Participant
    November 15, 2020 at 05:07

    1
    I did what you told me as you can see at the backend I have already made the translation and saved.
    2
    But it’s still just the same, no translation. Why?
    =============================================
    SOLVED!
    Turns out It’s not the plug-in XStore Core but the Child Theme has to be translated.

  • 1 2
    Viewing 20 results - 1 through 20 (of 21 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.