Speed in backend very slow when using xstore

This topic has 2 replies, 2 voices, and was last updated 1 years, 2 months ago ago by Tony Rodriguez

  • Avatar: Martine
    Martine
    Participant
    January 23, 2023 at 17:00

    Hello,
    I run a site with xstore, elementor pro and woocommerce. The site is nice and fast at the front (https://yoga-en-retraites.nl/), but deadly slow at the back. I also have some sites without xstore and they don’t have that problem. You are now waiting at least 10 but sometimes 20 seconds or more after each action. How can I get this faster?

    1 Answer
    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    January 24, 2023 at 07:13

    Hello @Martine,

    We have noticed that your website is loading quickly on the browser, however, you have mentioned that the backend admin panel is running slowly. To address this issue, we suggest that you take the following steps:

    1. Delete any unnecessary or disabled themes from the Appearance >> Themes section.
    2. Delete any unnecessary or disabled plugins.
    3. Delete any unnecessary or draft pages, blocks, products, and posts.

    Once these steps have been completed, please clear your browser cache and check back to see if the issue has been resolved. We hope that this will provide the desired results.

    Best Regards,
    8Theme’s Team

  • Viewing 2 results - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.