Sidebar on not behaving like it should when duplicating a page with wpml

This topic has 10 replies, 3 voices, and was last updated 4 years, 11 months ago ago by Olga Barlow

  • Avatar: emeliech
    emeliech
    Participant
    July 4, 2019 at 12:37

    I set sidebar none in 8theme Royal theme on a page, and when I duplicate that page the no sidebar setting is not transferred to the duplicate.

    Here is the settings for the english page: https://snag.gy/2ZuaTe.jpg

    Here are the settings for the duplicate: https://snag.gy/vQE4xq.jpg

    The result is a sidebar on ie the home page:

    https://snag.gy/T6Xtis.jpg

    Please, contact administrator
    for this information.
    9 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    July 4, 2019 at 14:59

    Hello,

    FTP is ok but Dashboard access is incorrect http://prntscr.com/oake8p
    Please, provide the correct password for the Dashboard to check your problem in more details.

    Regards

    Avatar: emeliech
    emeliech
    Participant
    July 5, 2019 at 13:38

    Please do try again. I have updated so it should work with those details.

    Kind regards,
    Marcus

    Avatar: emeliech
    emeliech
    Participant
    July 5, 2019 at 14:46

    We got a reply from WPML. They say we should set one of the Multilingual Content settings to “copy”.

    Please check their reply here: https://wpml.org/forums/topic/8theme-sidebar-on-duplicate-not-behaving-like-it-should/

    We are just not sure which one we should set to copy.

    When editing a page, these are the options we get:
    https://snag.gy/mygtT8.jpg

    Which should we set to copy?

    Thanks!

    Marcus

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    July 5, 2019 at 14:59

    Hello,

    It works. But we found that you are using CloudFlare and we won’t see any changes. Could you, please, enable dev mode in CloudFlare options and also enter your API http://prntscr.com/ob1dka to allow us to clear CDN cache.

    Regards

    Avatar: emeliech
    emeliech
    Participant
    July 6, 2019 at 18:10

    I have set it to dev mode in cloudflare and I have logged in with the api key in the admin so you should be able to control it.

    Kind regards,

    Marcus

    Avatar: emeliech
    emeliech
    Participant
    July 6, 2019 at 18:12

    I do not see a change,

    One of the custom fields needs to be set to copy on the Multilingual content setup.

    Please let somebody who is experienced with wpml take a look at this.

    Kind regards,

    Marcus

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    July 7, 2019 at 09:47

    Hello,

    I’ve passed this problem to our developers. They will be able to check it on Monday.
    We will let you know.

    Regards

    Avatar: emeliech
    emeliech
    Participant
    July 8, 2019 at 11:28

    Hello,

    Great, Thanks!

    I am looking forward to their answer today,

    Kind regards,

    Marcus

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    July 9, 2019 at 13:53

    Hello,

    This option should be enabled to copy sidebar position http://prntscr.com/oclsbv
    Try now.
    Also, we have updated theme to new version that will be available soon with updated options.

    Reagards

  • Viewing 10 results - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.