Max execution time: Requirement – 120 — System – 60

This topic has 7 replies, 3 voices, and was last updated 1 months ago ago by Andrew Mitchell

  • Avatar: JS7319
    JS7319
    Participant
    June 18, 2024 at 13:09

    Hello

    I am installing this theme for the first time. It was unsuccessful when I tried, but I’m not sure what the error message was exactly. However, this is an error which I can see from my Home Screen: Max execution time: Requirement – 120 — System – 60

    Is this potentially causing the installation failure? If so, what can I do about it?

    Thanks

    6 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    June 18, 2024 at 13:12

    Hello JS7319,

    Thank you for reaching out to us regarding your installation issue. We appreciate your patience and are here to assist you.

    Based on the error message you’ve described, it appears that the issue is related to the maximum execution time set on your server. The required execution time for the theme installation is 120 seconds, but currently, your system is set to 60 seconds. This discrepancy is likely causing the installation to fail.

    To resolve this, you will need to increase the maximum execution time on your server. You can do this by modifying the max_execution_time value in your PHP configuration file (php.ini). Here’s how you can adjust it:

    1. Locate your php.ini file (typically found in your server’s PHP installation directory).
    2. Open the php.ini file in a text editor.
    3. Search for the line max_execution_time = 60.
    4. Change the value from 60 to 120 or higher.
    5. Save the changes and close the file.
    6. Restart your web server to apply the changes.

    If you do not have access to modify the php.ini file directly, you might need to contact your hosting provider and request them to make this change for you.

    max_execution_time is a limit for the execution time while running the script. For example, if you import content and scripts need more than 60 secs then you may face the problem with demo content import. But depending on other server settings script could finish its work faster. So, if you didn’t face problems with theme options then don’t worry about this parameter. But it would be better to contact your hosting provider and ask to increase max_execution_time.

    Best Regards,
    8Theme’s Team

    Avatar: JS7319
    JS7319
    Participant
    June 18, 2024 at 19:07

    Hi,

    I have made the change, and I have clicked the rechecked button and it has introduced another new 3 issues.

    How do I move on from here.

    Thanks

    Files is visible for topic creator and
    support staff only.
    Avatar: JS7319
    JS7319
    Participant
    June 18, 2024 at 22:56

    Hello

    Please see update. I have updated the php.ini but the demo installation is still prompting me about the same two issues.

    Files is visible for topic creator and
    support staff only.
    Avatar: JS7319
    JS7319
    Participant
    June 18, 2024 at 22:57

    Here is the php.ini confirmation (it did not upload with the previous message)

    Files is visible for topic creator and
    support staff only.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    June 19, 2024 at 07:18

    Hello JS7319,

    Thank you for your prompt response. We apologize for the delay on our part.

    Regarding your inquiry, if you are making changes that are not visible, it likely indicates a server-side issue. Therefore, we recommend that you contact your hosting provider and request them to implement the settings found at the following link: [XStore Theme Requirements](https://xstore.helpscoutdocs.com/article/60-xstore-theme-requirements). Once these adjustments have been made, please clear your cache https://prnt.sc/xHZB5Vg03NJv After these steps, everything should function correctly.

    Best Regards,
    8Theme’s Team

    Avatar: Andrew Mitchell
    Andrew Mitchell
    Support staff
    June 19, 2024 at 14:08

    Dear JS7319,

    As we continue our mission to exceed expectations, your insights become increasingly valuable. Could we, with all due respect, request your thoughtful feedback by giving our theme a deserved 5-star rating on ThemeForest?

    Click here to share your valuable perspective: https://themeforest.net/downloads

    Your time and trust are highly appreciated!

    Best Regards,
    The 8Theme Team

  • Viewing 7 results - 1 through 7 (of 7 total)

The issue related to '‘Max execution time: Requirement – 120 — System – 60’' has been successfully resolved, and the topic is now closed for further responses

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.