Main Menu Overwriting Secondary Menu in Electronics Template

This topic has 9 replies, 3 voices, and was last updated 6 years, 5 months ago ago by Olga Barlow

  • Avatar: smbuckley2
    smbuckley2
    Participant
    January 25, 2018 at 18:09

    Losing my mind over this one. No matter how many times I delete, change location, or edit the contents of the menus I’ve made, the main menu always overwrites the secondary (vertical) menu on the home page. See here: https://bestskateboardreviews.com/

    I’ve enabled the secondary menu, set the display location as secondary for one menu, and main for another menu, but the main menu content displays on both the vertical and horizontal menus.

    I even changed the color of the secondary menu to purple just to verify that it is indeed pulling the secondary menu content, and sure enough, it turns purple, but still displays the main menu content. Its maddening.

    Before you ask, I have the PHP max_input_vars set to 8000 and I’ve picked “Advanced” as my header type already. Any help would be appreciated.

    Please, contact administrator
    for this information.
    8 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    January 26, 2018 at 09:59

    Hello,

    We’ve re-saved header settings. Please check menu now.

    Regards

    Avatar: smbuckley2
    smbuckley2
    Participant
    January 26, 2018 at 17:30

    So I logged into the dashboard to look at the menus, dismissed one of the plugin notices that your reset had prompted, the whole admin crashed, and now I get a “Are you sure you want to do this? Please try again.” error every time I try to log in?

    Went from bad to worse somehow.

    Avatar: smbuckley2
    smbuckley2
    Participant
    January 26, 2018 at 17:45

    Nevermind, I cleared the cache and that seemed to fix the issue. I can now log in ok. Verifying the menu fix now.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    January 26, 2018 at 19:39

    Ok, great.
    Feel free to contact us if you need any other help.

    Regards

    Avatar: smbuckley2
    smbuckley2
    Participant
    January 26, 2018 at 19:52

    After some testing, menu does seem to be working as intended. Thank you.

    The issue was that the 8Theme Layout Options drop-down menu had disappeared entirely from the edit home page screen. Is this a known bug? What did you guys do to fix it?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    January 29, 2018 at 10:08

    Hello,

    CMB2 plugin was disabled on your site. This plugin is required http://xstore.helpscoutdocs.com/article/36-included-plugins so we activated the plugin on your site.

    Regards

    Avatar: smbuckley2
    smbuckley2
    Participant
    January 29, 2018 at 17:18

    Oh, ok. I didn’t realize that plugin was required. Thanks for the thorough response.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    January 29, 2018 at 17:29

    You are welcome!

    Regards

  • Viewing 9 results - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.