Linked Products - by DebbieC - on WordPress WooCommerce support

This topic has 6 replies, 3 voices, and was last updated 3 years, 6 months ago ago by Olga Barlow

  • Avatar: DebbieC
    DebbieC
    Participant
    August 3, 2020 at 10:19

    When adding new products I have always filled in the ‘Linked Products’ section for Upsells and Cross-sells so the products I choose show at the bottom of each product page under ‘Related Products’ and then on the Cart pages.

    However, the system seems to display random products in these sections instead of the ones I have specifically chosen. I am not sure how long it has been like this, but I really want to display my chosen products, not the random ones. How can this be changed?

    5 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 3, 2020 at 10:30

    Hello,

    I don’t see Upsells on the product page, only related products.

    Related Products is a section on some templates that pulls products from your store that share the same tags or categories as the current product.
    These products cannot be specified in the admin, but can be influenced by grouping similar products in the same category or by using the same tags.

    To enable Upsells go to Theme Options > WooCommerce > Single products > Location Of Upsell Products > After content.

    Regards

    Avatar: DebbieC
    DebbieC
    Participant
    August 3, 2020 at 15:06

    Okay, thanks that works now and the upsell products I have chosen are showing, but I don’t want ‘Related Products’ + a row of ‘Upsell’ products. Can the related products section be removed/disabled?

    What about the ‘Cross-Sells’, how can I enable that for the cart page instead of ‘related products’?

    On my old theme, ‘Related Products’ were the ones I chose in ‘Upsells’. I presumed this theme worked the same way, I have only just noticed it doesn’t.

    Avatar: John Holden
    John Holden
    Support staff
    August 4, 2020 at 05:48

    Hi,

    – Theme Options > WooCommerce (Shop) > Single product page > Related products

    – You added Upsells and Cross-sells products https://docs.woocommerce.com/document/related-products-up-sells-and-cross-sells/

    Cross-sells appear on the cart page after adding your product to the cart. Upsells could appear on the single product if you add the appropriate element to product layout http://prntscr.com/sxbkfe

    Regards,
    Hung PD

    Avatar: DebbieC
    DebbieC
    Participant
    August 10, 2020 at 09:39

    Hi,

    I know HOW to add cross-sells and up-sells. I have added them to all products. My point is that the cross-sells I have added are NOT showing on the cart page. It must be something in the theme that prevents this as they always showed on my previous theme.

    I also asked if it was possible to remove/disable the related products section as I do not need up-sells and ‘related’ to show on the product page.

    Debbie

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    August 10, 2020 at 13:27

    Hello,

    1) You can disable the related products in Theme Options > WooCommerce > Single product page > Related products > Off.

    2) Provide us with link to product that has the Cross-sells but they do not appear on the cart page. Because I don’t see the issue http://prntscr.com/tx4w1w

    Regards

  • Viewing 6 results - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.