Internal Server Error 2 - by Edgar - on WordPress WooCommerce support

This topic has 8 replies, 2 voices, and was last updated 4 years, 3 months ago ago by Olga Barlow

  • Avatar: profile
    Edgar
    Participant
    April 23, 2020 at 19:42

    Hi,
    I’m still getting Internal Server Error.
    I’ve launched new, clean WP+Woocommerce instance + Store and Loco translation
    After synchronisation of translations I’m getting this error
    [Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (3.9.243.112, line 0) http://3.9.243.112/?customize_changeset_uuid=f9d99be1-693f-4c7c-a8e2-38452c099cfb&customize_theme=xstore-child&customize_messenger_channel=preview-0&customize_autosaved=on

    Please, contact administrator
    for this information.
    7 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 23, 2020 at 19:55

    Hello,

    Check the server error log. What errors di you have there?

    Regards

    Avatar: profile
    Edgar
    Participant
    April 23, 2020 at 20:03

    [Thu Apr 23 18:00:07.788879 2020] [pagespeed:error] [pid 2092:tid 140616650204928] [mod_pagespeed 1.13.35.2-0 @2092] PageSpeed Serf fetch failure rate extremely high; only 27 of 83 recent fetches fully successful; is fetching working?
    [Thu Apr 23 18:42:52.193432 2020] [substitute:error] [pid 2092:tid 140616734131968] [client 89.238.186.229:52427] AH01328: Line too long, URI /index.php, referer: http://3.9.243.112/wp-admin/customize.php
    [Thu Apr 23 18:42:52.193483 2020] [proxy_fcgi:error] [pid 2092:tid 140616734131968] (12)Cannot allocate memory: [client 89.238.186.229:52427] AH01075: Error dispatching request to : (passing brigade to output filters), referer: http://3.9.243.112/wp-admin/customize.php
    [Thu Apr 23 18:43:09.584383 2020] [substitute:error] [pid 2092:tid 140617261975296] [client 89.238.186.229:52438] AH01328: Line too long, URI /index.php, referer: http://3.9.243.112/wp-admin/customize.php
    [Thu Apr 23 18:43:09.584408 2020] [proxy_fcgi:error] [pid 2092:tid 140617261975296] (12)Cannot allocate memory: [client 89.238.186.229:52438] AH01075: Error dispatching request to : (passing brigade to output filters), referer: http://3.9.243.112/wp-admin/customize.php
    [Thu Apr 23 19:01:36.169120 2020] [substitute:error] [pid 2092:tid 140617128589056] [client 89.238.186.229:53265] AH01328: Line too long, URI /index.php, referer: http://3.9.243.112/wp-admin/customize.php
    [Thu Apr 23 19:01:36.170202 2020] [proxy_fcgi:error] [pid 2092:tid 140617128589056] (12)Cannot allocate memory: [client 89.238.186.229:53265] AH01075: Error dispatching request to : (passing brigade to output filters), referer: http://3.9.243.112/wp-admin/customize.php

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 23, 2020 at 20:05

    Hello,

    I think you need to contact your hosting provider. Looks something is not ok with server settings (probably max input vars limit). Errors are not related to theme files.

    Regards

    Avatar: profile
    Edgar
    Participant
    April 24, 2020 at 11:53

    Hello,
    I’ve uncommented and changed max input vars up to 10000 in php.ini but keep getting the same error.
    I’ve made new clean installation of WP, changed max input vars to 10000, restarted services, installed theme + loco translation – and I’m still getting Internal Server Error…

    Please note, that IP address has been changed

    Regards, E.

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 24, 2020 at 12:03

    Hello,

    Check this topic and try solution mentioned there https://community.bitnami.com/t/error-500-on-aws-wordpress-using-elementor/63135 Maybe it helps you.

    Regards

    Avatar: profile
    Edgar
    Participant
    April 24, 2020 at 12:35

    Olga, thanks for promt reply
    But I’m using WPBakery theme and don’t have any options they are discussing. So I’ve just checked memory settings – there is 512 Mb allocated to server, when theme requires only 128 Mb.

    Anyway, I’ve found solution in different topic, so I’ll leave it here in case somebody experiences same issue:
    you need to add

    <Location "/">
       SubstituteMaxLineLength 20m
    </Location>

    in the end of htaccess.conf file, located in /wordpress/conf directory

    Thank you for help, Olga!
    Have a nice day!

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 24, 2020 at 13:48

    Hello,

    Glad to hear that you sorted out.

    Regards

  • Viewing 8 results - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.