I have several problems with the speed of the website and Amp

This topic has 4 replies, 2 voices, and was last updated 1 years, 7 months ago ago by Rose Tyler

  • Avatar: oscardc
    oscardc
    Participant
    November 3, 2022 at 09:54

    I have several problems
    1- The website is slow and I have already done all the known configurations, I have tried it with all the plugins and it is still the same, even with the AMP it is slow.
    2- The pop-up window for quick view or preview of the products is blocked, that is, the pop-up window will open but it doesn’t work, the image stays loading and the links don’t work.
    3- Is it possible to change the configuration of the home page, of AMP of the categories and products, example, the categories the design is round and slider, can it be changed?
    $- Is it possible to add more sections to the AMP home page or multiply the existing ones?

    ALSO I HAVE A WARNING NOTICE FROM WOOCOMMERCE.

    (Your theme (XStore Child) contains outdated copies of some WooCommerce template files. You may need to update these files to ensure they are compatible with the current version of WooCommerce. Tips to fix this:

    Update your theme to the latest version. If no update is available please contact your theme author to ask about compatibility with the current version of WooCommerce.)

    CAN YOU HELP ME WITH THIS?

    Thank you

    3 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 3, 2022 at 13:20

    Hello,

    Please open up separate topics for different questions.

    1/ Read this article first – https://xstore.helpscoutdocs.com/article/100-how-to-speed-up-my-website
    https://prnt.sc/kAd9TZGouMvh – Read these posts about DOM https://docs.wp-rocket.me/article/1412-avoid-an-excessive-dom-size https://isotropic.co/avoid-an-excessive-dom-size-on-your-wordpress-website/
    Edit your page and Product elements and enable Lazy loading for the Product elements. It should reduce the DOM structure. Also, you may try to reduce the DOM results on the page by reducing the number of sections of the page/elements in the footer or header.
    Check this topic – https://www.8theme.com/topic/high-usage-cpu/
    https://prnt.sc/N-mxXa3G3IbChttps://authoritywebsiteincome.com/4-ways-to-use-cookie-free-domains/ https://kinsta.com/blog/make-fewer-http-requests/ https://wpengine.com/resources/how-to-enable-gzip-compression-for-wordpress/

    2/ Try to disable all the third-party plugins (including cache plugins), that does not come bundled with XStore https://xstore.helpscoutdocs.com/article/36-included-plugins , clear the cache of the browser, and check then. Maybe one of the additional plugins is the reason for the problem.

    3, 4/ https://xstore.helpscoutdocs.com/category/112-amp-plugin

    5/ We will release new theme update soon.
    You can downgrade WooCommerce plugin version or wait for the update.
    Next time do not update WooCommerce before the theme update. Info about compatibility you can find in our changelog.

    Regards

    Please contact administrator
    for this information.
    Avatar: oscardc
    oscardc
    Participant
    November 3, 2022 at 14:08

    Thank you very much for your quick response, I will work again on the indications you gave me about the speed of the Website
    Also, if possible, could you answer me about the questions I asked you about…
    (The products quick view or preview popup is blocked, i.e. the popup will open but it doesn’t work, the image stays loading and the links don’t work.)

    About the AMP version I will open another topic to help me with this..

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 4, 2022 at 08:55

    Hello,

    Thanks for the reply.
    “(The products quick view or preview popup is blocked, i.e. the popup will open but it doesn’t work, the image stays loading and the links don’t work.)” – please try to disable all the third-party plugins (including cache plugins), that does not come bundled with XStore https://xstore.helpscoutdocs.com/article/36-included-plugins , clear the cache of the browser, and check then. Maybe one of the additional plugins is the reason for the problem.

    Regards

  • Viewing 4 results - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.