I can’t update XStore Core to 4.1.3 version.

This topic has 6 replies, 3 voices, and was last updated 2 years, 1 months ago ago by Olga Barlow

  • Avatar: Sam_Va
    Sam Va
    Participant
    April 12, 2022 at 16:46

    Hi here,

    I can’t update XStore Core to 4.1.3 version.

    When I try to update the plugin but the following error message pops up:

    Update failed: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.

    I contacted my host support, they fixed permissions stuff but still I can’t update the plugin> Please help.

    Thanks in advance.

    Please, contact administrator
    for this information.
    5 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 13, 2022 at 06:57

    Hello,

    Try to update the plugin through FTP
    https://xstore.helpscoutdocs.com/article/37-plugins-update

    Regards

    Avatar: Sam_Va
    Sam Va
    Participant
    April 28, 2022 at 12:08

    I did try many time via FTP, I also contacted my host nothing change.
    Please help,
    Thank you

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 28, 2022 at 15:42

    Hello,

    1/ This issue is caused by incorrect file permissions on your server (rather than being a problem with the plugin itself). WordPress isn’t able to properly access its own plugins folder, and as a result, can’t put the updated plugins files in there.
    Here is an article that can help you to solve the issue:
    https://akashicseer.com/web-development/wordpress-update-failed-the-update-cannot-be-installed-because-we-will-be-unable-to-copy-some-files-this-is-usually-due-to-inconsistent-file-permissions/
    Did it help?
    2/ If you have any permissions issues during auto update it would be better to contact hosting provider to fix it because it’s related to your server settings.
    If you prefer to update the plugin via FTP we can help you with this. Just provide us with Dashboard and FTP access to your site.

    Regards

    Avatar: Sam_Va
    Sam Va
    Participant
    April 29, 2022 at 05:43

    I would appreciate if you can do it via FTP.

    Thank you in advance for your help.

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 29, 2022 at 09:59

    Hello,

    We can’t remove the folder of the plugin even using FTP because of the permissions https://prnt.sc/pA1wIRxV-1Xh So, I renamed the folder to /wp-content/plugins/et-core-plugin-old and installed the new version of plugin. Delete the mentioned et-core-plugin-old folder.

    Regards

  • Viewing 6 results - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.