Filters dont work without update products

This topic has 14 replies, 3 voices, and was last updated 2 years, 1 months ago ago by Rose Tyler

  • Avatar: ManLe
    ManLe
    Participant
    April 14, 2022 at 21:30

    As you can see in the video 1 filter don’t work. If I go at admin and save attributes and click update the filter work for the product I updated even if I don’t change the attributes. Watch the video 2.

    Please, contact administrator
    for this information.
    13 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 15, 2022 at 15:45

    Hello,

    Were products created manually or imported? It looks like an issue with import, so we can’t help in this case.
    We can’t check your site, there is a critical error shown. Provide temporary FTP access, so we can take a closer look.

    Regards

    Avatar: ManLe
    ManLe
    Participant
    April 15, 2022 at 15:51

    You can check now. There was a problem with menu. The products are imported.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 17, 2022 at 13:17

    Hello,

    The products are imported.

    This could be the reason of the issue. Try to go to WooCommerce > Status > Regenerate the product attributes lookup table > regenerate all the products you have and try to filter after that.

    Regards

    Avatar: ManLe
    ManLe
    Participant
    April 19, 2022 at 22:18

    It doesnt work.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 20, 2022 at 14:57

    Have you cleared cache? As for me, filters work fine now. Please check one more time.

    Regards

    Avatar: ManLe
    ManLe
    Participant
    April 20, 2022 at 15:00

    It works only for some products. Not all.

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 21, 2022 at 20:42

    Hello,

    Could you, please, enable the Storefront theme (default WooCommerce theme), add the filter by attribute widgets to the sidebar, and test if you have the same issue with the filtering when the Storefront theme is enabled. Provide us with the screenshot or video of how it works with the default theme.

    Regards

    Avatar: ManLe
    ManLe
    Participant
    April 22, 2022 at 11:02

    It works fine with storefront. :/

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 22, 2022 at 16:41

    Hello,

    Could you, please, use the Recordit tool and make a video of how it works with the Storefront and with our theme using the same filters to explain the issue in more detail?

    Regards

    Avatar: ManLe
    ManLe
    Participant
    April 22, 2022 at 16:49

    As you can see at video (1) the filters working for all products. At video (2) for xstore not all products are visible, just 40-50 products of the selected brand.

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 22, 2022 at 17:08

    Hello,

    I checked your site and with our theme it displays the same 43 products if you filter by the Tommy Hilfiger

    Don’t understand the problem.

    Regards

    Please contact administrator
    for this information.
    Avatar: ManLe
    ManLe
    Participant
    April 23, 2022 at 12:06

    It works fine. Thank you.

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 23, 2022 at 15:14

    You’re welcome!

    Regards

  • Viewing 14 results - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.Log in/Sign up

Helpful Topics

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.