Filter products by attribute not showing all options

This topic has 4 replies, 2 voices, and was last updated 4 years, 5 months ago ago by Rose Tyler

  • Avatar: Alexio
    Alexio
    Participant
    December 13, 2019 at 15:47

    Hi,
    I’m using the “Filter products by attribute” widget and i have a problem because after a filter is selected, you cannot quickly change to another filter, you have to click X to remove current filter and then select a new one which makes it very difficult for the user.

    In your demo, i see it works the way i want but maybe i have some setting wrong, please advice.

    Please, contact administrator
    for this information.
    3 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    December 13, 2019 at 16:04

    Hello,

    Please check how it works with a default theme (Storefront). If the problem persists with XStore theme only, provide temporary wp-admin and FTP access.

    Regards

    Avatar: Alexio
    Alexio
    Participant
    December 14, 2019 at 13:50

    Hi,

    After a lot of testing, i figured out it’s a Woocommerce bug.
    When an attribute slug is long, the widget “Filter Products by attribute” doesn’t work for Display type-> Dropdown and Query Type-> AND.
    I will open a ticket in woocommerce support.

    Thanks.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    December 14, 2019 at 14:14

    Hello,

    Thanks for letting us know.

    Regards

  • Viewing 4 results - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.