Featured Images on CPT are not appearing – conflict

This topic has 11 replies, 4 voices, and was last updated 2 years, 11 months ago ago by Rose Tyler

  • Avatar: malizacp
    malizacp
    Participant
    April 21, 2021 at 16:57

    Hi,

    I built a website with Crocoblock last week, and had a problem having the featured image display on the custom post type. I changed themes (from Xstore to Kava), and the featured image returned in the post type.

    I am now facing the same thing on another site, but when using Custom Post Type UI (plugin). Featured image is specified to appear when adding a new post, but the option to add a featured image is not showing.

    This leads me to believe that there is a conflict between your theme and specifying a featured image in custom post types.

    Everything was fine until the latest update. The CPT UI’s all worked before then.

    10 Answers
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 21, 2021 at 17:05

    Hello,

    Provide us with WP Dashboard and FTP access to your site and link to the page where you have the issue.
    We’ll check and try to help you.

    Regards

    Avatar: malizacp
    malizacp
    Participant
    April 22, 2021 at 10:21

    All details in private content area

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 22, 2021 at 19:10

    Hello,

    Fixed. The fix was made in xstore/theme/theme-setup.php if you need it for another site.

    Regards

    Avatar: aryandco
    aryandco
    Participant
    April 24, 2021 at 18:18

    Hi, I´m having exactly the same issue. I´ve tried to create a custom post type with both crocoblock and CPT UI but the featured image is missing. Could you please assist me with that?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 25, 2021 at 08:13

    Hello Aryandco,

    Please submit a new topic, provide temporary wp-admin and FTP access.

    Regards

    Avatar: malizacp
    malizacp
    Participant
    April 25, 2021 at 16:36

    Thank you – what should I do to carry this change through to my other sites?

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    April 26, 2021 at 10:50

    Hello,

    You are welcome. If all the other sites use the same version of theme and XStore core plugin then just copy the mentioned file to these sites. Or edit xstore/theme/theme-setup.php, find add_theme_support( 'post-thumbnails', array('post', 'page', 'product', 'etheme_portfolio') );
    and replace with
    add_theme_support( 'post-thumbnails' );

    Regards

    Avatar: aryandco
    aryandco
    Participant
    April 26, 2021 at 12:13

    Hi Rose,
    thanks for the reply, here are the details.

    Please contact administrator
    for this information.
    Avatar: aryandco
    aryandco
    Participant
    April 26, 2021 at 12:30

    Hi Rose,
    I copy/pasted the codes above by Olga and it works.
    Thanks guys

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    April 26, 2021 at 12:39

    Hello Aryandco,

    Great. Thanks for letting us know.
    Have a nice day!

    Regards

  • Viewing 11 results - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.