Checkout payment field sporadically not working

This topic has 4 replies, 2 voices, and was last updated 1 year, 5 months ago ago by Rose Tyler

  • Avatar: Ffoot
    Ffoot
    Participant
    August 31, 2022 at 11:39

    Hi,

    I performed some test purchases earlier today without issue, but for some reason, the payment field at checkout is now showing most of the time as blank and can’t be clicked in order to input card details.

    https://www.evernote.com/l/ABgdZEYcX5pKBYo9rNeNQz2rhJDAjAmKduY

    I saw another thread on the forums that indicated the issue might be with the JS minimise setting in the SG Optimiser plugin. While it seem to work fine once I disabled that setting, the problem has occurred again, which makes me wonder if the issue is being caused by something else.

    Can you advise?

    Thanks

    Please, contact administrator
    for this information.
    3 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    September 1, 2022 at 09:55

    Hello,

    We do not see the problem right now – https://gyazo.com/70697fb628d937ccb89104e88d849d6a
    If it exists for you still, try to clear all cache and check one more time. Record a video for us. What browser do you use?

    Please try to disable all the third-party plugins (including cache plugins), that does not come bundled with XStore https://xstore.helpscoutdocs.com/article/36-included-plugins , clear the cache of the browser, and check then. Maybe one of the additional plugins is the reason for the problem.

    Regards

    Avatar: Ffoot
    Ffoot
    Participant
    September 1, 2022 at 10:10

    Hi, Thanks for the reply.

    It seems to be a conflict with the SiteGround (my host) Optimiser plugin.

    I deactivated it and the problem didn’t occur.

    Can you suggest a fix, as it would be good to use the advised plugins from my host?

    Thanks again.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    September 1, 2022 at 12:56

    Hello,

    Try to disable javascript minification in the settings of the plugin.
    If this doesn’t help, try to contact the support of the plugin.

    Regards

  • Viewing 4 results - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.