Check Boxes are empty when they are selected

This topic has 11 replies, 2 voices, and was last updated 1 years, 8 months ago ago by Tony Rodriguez

  • Avatar: Coroveisc
    Coroveisc
    Participant
    September 26, 2022 at 23:18

    Hello sir,madam

    In the shop page when we select a filter on the sidebar, the check box remains blank without a check symbol and it is pretty confuse for the clients
    I have attached a screenshot also

    https://we.tl/t-4H27lF2vOa

    Please, contact administrator
    for this information.
    10 Answers
    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    September 27, 2022 at 05:37

    Hello, @Coroveisc,

    Could you please try to use the default Filter by attribute widget instead of the 8theme Swatches filter widget? Hope this will work for you.

    https://postimg.cc/QH7bYv4j
    https://postimg.cc/xJqGvZND

    Regards 8Themes Team.

    Avatar: Coroveisc
    Coroveisc
    Participant
    October 7, 2022 at 13:52

    ok i have tried this but it works only for only one attribute, all the other attributs doesnt appear to the sidebar, can you please check it out?

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 8, 2022 at 06:10

    Hello, @Coroveisc,

    I have checked your site and found that everything is set to ok, widgets and theme options all. Also, there is no such third-party plugin that conflict and causes the issue. But you are not using the latest version of the theme https://postimg.cc/LJ4hFZG7 and its core plugin so please first try to update the theme to the latest version then update the theme necessary plugins to the latest version. Then check back to your site after clearing the browser cache. I hope your issue will be resolved.

    Here is an article to know how to update the theme step by step: https://xstore.helpscoutdocs.com/article/63-theme-update

    Regards 8Themes Team.

    Avatar: Coroveisc
    Coroveisc
    Participant
    October 10, 2022 at 09:06

    I have updated and delete the cahce but i am facing the same issue. Can we add a class to your 8theme filters in order to enable the checkbox when it is selected?

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 10, 2022 at 09:34

    Hello, @Coroveisc,

    1- Actually, you have a cache issue because after the update the filter now appears on the shop page before it was not. Check the video for a better reference: https://streamable.com/zizsc9 and check back to your site after clearing the browser cache.

    2- No, There is no option in the widget settings to add any class. The thing is when you choose any filter from the site it will appear on the active filter section like this: https://postimg.cc/2VbbMWgG if you remove the active filter widget from the shop sidebar then it will show the checked filter as you said check the image: https://postimg.cc/34t1SGz7

    Regards 8Themes Team.

    Avatar: Coroveisc
    Coroveisc
    Participant
    October 11, 2022 at 09:40

    In my case doesnt work look this video https://we.tl/t-PlsKF3b4mW

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 11, 2022 at 10:17

    Hello, @Coroveisc,

    Actually, the issue is in the attributes you created on your site. That’s why the other does not appear. If the theme has any issues then the brand and price filter will also not appear. I also, test the issue by creating new attributes and it works fine. I have captured a detailed video for you please watch it complete: https://streamable.com/34y8g3

    So now you have to create attributes again and remove all the old from your site completely. I hope your issue will be resolved.

    Regards 8Themes Team.

    Avatar: Coroveisc
    Coroveisc
    Participant
    October 14, 2022 at 16:30

    Hello, i have delete everything and create new, and i am still facing the same problem. Please help me i also update to the latest. No cahcing plugin. We must found a solution asap

    Avatar: Coroveisc
    Coroveisc
    Participant
    October 14, 2022 at 16:52

    i fix it

    Avatar: Tony Rodriguez
    Tony Rodriguez
    Support staff
    October 15, 2022 at 05:19

    Hello, @Coroveisc,

    Sound’s Good!! that you have managed to solve the issue.
    You are the best πŸ™‚

    Feel free to contact us again if you need more help in the future but with a fresh new topic for every single issue.

    Thanks for contacting us.
    Have a nice weekend πŸ™‚

    Topic Closed.
    Regards 8Themes Team.

  • Viewing 11 results - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.