Cart Widget not working/showing in header

This topic has 32 replies, 4 voices, and was last updated 1 years, 7 months ago ago by Rose Tyler

  • Avatar: MagineM
    MagineM
    Participant
    November 10, 2022 at 20:31

    Hi,
    Recently the cart widget has stopped showing in the header of my client’s site. Have tried all sorts of things, but not sure what is causing this.
    The widget is enabled in the settings, but nothing.

    31 Answers
    Avatar: MagineM
    MagineM
    Participant
    November 10, 2022 at 20:49

    Could it possibly have something to do with the outdated WooCommerce theme files after the recent WooCommerce updates?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 11, 2022 at 03:46

    Hello,

    Please download the theme and Core plugin from this page – https://www.8theme.com/downloads and do the update manually https://www.8theme.com/demo/docs/legenda/Theme_Update.html https://www.8theme.com/demo/docs/legenda/Plugins/Plugins_Update
    After the update, you will need to wait up to 4 hours while Woocommerce cache will be cleared and messages about outdated files disappear.

    About the Cart widget, there can be another reason. Please provide temporary wp-admin and FTP access, we will check the situation more deeply.

    Regards

    Avatar: MagineM
    MagineM
    Participant
    November 11, 2022 at 07:21

    Hi Rose, thank you for the reply. As mentioned though, I am running the latest Legenda Theme & Core (which I downloaded and manually updated).
    There are still outdated WooCommerce theme files.
    Unfortunately giving admin access at this point in time is not really an option as this is a live site, and we can’t have any downtime.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 11, 2022 at 08:11

    Hello,

    You need to do the update right now, because current achives contain compatibility with the latest WooCommerce, just number of version was not changed, so please follow my recommendation.

    Regards

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 11, 2022 at 08:23

    Theme Options > Header > Enable cart widget > On.
    If this option is enabled, check if there is any changes in your child theme files that may affect it.

    Regards

    Avatar: MagineM
    MagineM
    Participant
    November 11, 2022 at 08:30

    Hi, ah, ok. Will do.

    Avatar: MagineM
    MagineM
    Participant
    November 11, 2022 at 08:32

    Cart widget is set on and there is no customisation in the child theme template files.

    Avatar: MagineM
    MagineM
    Participant
    November 11, 2022 at 09:21

    I’ve updated the theme & core and all files are up to date now. But cart widget still not functioning :(. Probably is something in the setup or another plugin or something… but have no idea where and there are also no obvious errors.

    Avatar: MagineM
    MagineM
    Participant
    November 11, 2022 at 09:53

    Hi, a quick update. I’ve tested the site through the troubleshooting mode with the child theme and then the parent theme and only Legenda Core, Redux Framework, WPBakery & WooCommerce enabled.
    Each time the outcome is the same, no cart widget in the header and the search box shows on the left and the right of the logo. 🙁

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 11, 2022 at 12:23

    Hello,

    In this case, we need to take a closer look at your settings of the site, so temporary wp-admin and FTP access are needed. If your site is live, create a staging site (a full copy of the live site, so we can do tests there).

    Regards

    Avatar: pablostevens
    pablostevens
    Participant
    November 25, 2022 at 21:41

    I can confirm, I’m having the same issue with with any headers that contain the cart. The cart does not show. As a work around I just switched the header to variant#6 which does have a cart link in the top bar just to visitors can have functionality.

    Also noticed when search bar in header is turned on, the search bar appears twice, once where it’s supposed to be and once where the cart is supposed to be.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 26, 2022 at 08:45

    Hello @Pablostevens,

    With which header types do you get mentioned problems? Please describe in more detail.

    Regards

    Avatar: pablostevens
    pablostevens
    Participant
    November 26, 2022 at 16:10

    Hey Rose,

    Thanks so much for responding. I made a video for you. It’s just easier to show you.

    https://vimeo.com/775305247/5866598600

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 26, 2022 at 21:29

    Hello @Pablostevens,

    Thank you very much for your kind words, and for the detailed video explanation. Strange, but we do not see mentioned problems on our test site. Could you, please create a staging site (a full copy of the live site), and provide temporary wp-admin and FTP access, so we can do tests there?
    Or provide your Theme Options file first, and we will import it on our site and check the result. Go to Theme Options > Import/Export > Export file > upload the file on a filesharing service and provide the URL via the Private Content area.

    Regards

    Avatar: pablostevens
    pablostevens
    Participant
    November 27, 2022 at 18:01

    OK created the dev environment. Just to be safe I also deactivated all the other plugins and re-installed Legenda theme. The problem still exists.

    I’m running PHP 8.0 just FYI, sometimes that’s important.

    Please contact administrator
    for this information.
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 28, 2022 at 07:00

    Thanks for the reply.
    We can’t connect FTP or open your site. please check. Are there any restrictions by IP or something else?

    Regards

    Avatar: pablostevens
    pablostevens
    Participant
    November 28, 2022 at 14:25

    Sorry about that. I have various country blocking enabled to prevent spam. What country are you connecting from?

    Avatar: MagineM
    MagineM
    Participant
    November 28, 2022 at 14:48

    Hi, I ended having to tweak the header template to get the Cart widget to show/work properly. Didn’t seem to be any other way.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 28, 2022 at 14:58

    Hello @Pablostevens ,

    Unblock it for Ukraine, please.

    Regards

    Avatar: pablostevens
    pablostevens
    Participant
    November 28, 2022 at 16:57

    OK sorry about that, I whitelisted the Ukraine. Let me know if any problems.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 28, 2022 at 17:21

    Hello @Pablostevens,

    Thanks for the reply.
    FTP directory is empty – https://gyazo.com/4fe29cb360b707b8621fe5ce0faca710
    Check the destination folder of our user, or ask your hosting provider for help with this, we need access to your WP installation.

    Regards

    Avatar: pablostevens
    pablostevens
    Participant
    November 28, 2022 at 18:18

    Ok sorry about that, please try again, I gave you access to the public_html folder. The dev environment is in the “dev” folder.

    NOTE: The main public_html folder has the LIVE site.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 29, 2022 at 09:38

    Hello,

    Fixed.
    Changes were done in \themes\legenda\header.php file – https://we.tl/t-QDPnI9UO2E

    Regards

    Avatar: pablostevens
    pablostevens
    Participant
    November 29, 2022 at 15:57

    Thank you, thank you! That works and fixes it both on desktop and mobile!

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    November 29, 2022 at 18:21

    Hello,

    You’re welcome!
    Have a nice day!

    Regards

    Avatar: Vintage4stars
    Vintage4stars
    Participant
    December 6, 2022 at 10:38

    We have the exact same problem, two search field and no cart in header.
    If we turn off search, both disappear.
    But no change if we try ON/OFF on the cart.
    Any solution without giving you access?
    Same problem as pablostevens.

    Avatar: MagineM
    MagineM
    Participant
    December 6, 2022 at 10:59

    Ok, so seeing there are a number of folks with this issue, here is how I resolved it:

    In your child theme, place a copy of the Legenda header.php template. Then do the following edits:

    Comment out line 223 <!-- <?php echo etheme_search(array()); ?> -->

    Then place the following line of code <div class="your-class-here"><?php etheme_top_cart(); ?></div> in just after the <?php endif ?> on line 225.

    Hope this helps. Worked for me.

    PS: Header settings in Theme Settings – Everything turned OFF, except for Enable cart widget & Enable search form in header are ON.

    Avatar: MagineM
    MagineM
    Participant
    December 6, 2022 at 11:14

    I do see that there is a theme update though… so maybe that will fix the issue. Am going to be testing the update later this week.

    Avatar: Vintage4stars
    Vintage4stars
    Participant
    December 6, 2022 at 11:45

    Thanks for your solution, we try later!
    Best regards

  • 1 2
    Viewing 30 results - 1 through 30 (of 32 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.