Hiding variations on shop page main layout to keep it looking tidy

This topic has 6 replies, 2 voices, and was last updated 2 years, 2 months ago ago by Rose Tyler

  • Avatar: Niddy
    Niddy
    Participant
    March 5, 2022 at 12:11

    Hi,

    On main shop page using demo 4 classic, the custom css is not doing anything when using in-page css overrides. Basically the shop page looks awful with default view because it showing the variations which we wanted to hide.

    Using custom css on the actual shop page should hide these using –

    .st-swatch-in-loop {
        display: none !important;
    }

    But it has absolutely no effect – can you please check and clarify? It works fine on the main homepage as I have used same css there to hide them from the homepage slider widgets but why won’t the main shop classify the css override?

    See info in private.

    Thanks

    Please, contact administrator
    for this information.
    5 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 5, 2022 at 13:15

    Hello,

    Theme Options > WooCommerce > Shop elements > Variation swatches > Swatch Position (swatches position to display on the shop page) > Disable

    Regards

    Avatar: Niddy
    Niddy
    Participant
    March 5, 2022 at 13:20

    awesome thank you very much! I did try this but on the actual customizer it refreshes and they remain so I didn’t think it was right – however when you save it and then refresh front end they do disappear – albeit on customiser they are still showing as visible – just a small bug for your team to look at.

    Thanks again. 🙂

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 5, 2022 at 13:35

    Hello,

    You’re welcome!
    Have a nice day!

    Regards

    Avatar: Niddy
    Niddy
    Participant
    March 5, 2022 at 13:39

    Thanks again – just one last query, any idea why the main menu (mega menu) is not updating when I save it via static block…?

    Is it a setting I need to edit?

    Thanks

    edit – sorted, sorry seems to be a cache issue my side. Thanks again.

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 5, 2022 at 13:59

    Hello,

    Theme Options > Speed Optimization > Menu Dropdown Ajax Loading, Menu Dropdown Cache, Menu Cache, Static Blocks Cache > Off. Activate mentioned options once all changes to the header/menu will be done.

    Regards

  • Viewing 6 results - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.