Account, Liked, Cart - by Charles Lim - on WordPress WooCommerce support

This topic has 9 replies, 3 voices, and was last updated 4 years, 11 months ago ago by Olga Barlow

  • Avatar: Charles_Lim
    Charles Lim
    Participant
    March 22, 2019 at 08:33

    At home page, account button does not direct to registration and register link directs to homepage. Liked and cart does not work as intended on home page as well. How do I set it up properly and change the colour of the fonts? As you can see it is dark.

    8 Answers
    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 22, 2019 at 08:38

    Hello,

    You need to install default pages of Woocommerce. Go to WooCommerce > Status > Tools > Create default WooCommerce pages > click on “Create pages”. Read more – https://docs.woocommerce.com/document/woocommerce-pages/
    To enable registration, navigate to Settings > General > Membership and mark Anyone can register, then go to Woocommerce > Settings > Accounts > Customer registration > Enable customer registration on the “My account” page.
    Typography settings you can find in Theme Options – https://prnt.sc/n1bkk9

    Regards

    Avatar: Charles_Lim
    Charles Lim
    Participant
    March 22, 2019 at 08:48

    I have done the steps you have mentioned. However, the account, wishlisted and cart buttons do not redirect accordingly. As for typography, where will I be able to change specifically under Account “lost password?” and “Register?”

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 22, 2019 at 09:08

    Hello,

    Were “My account”, “Cart”, “Checkout”, “Shop” pages imported via Tools of WC? Please check the Pages section. If so, make sure that pages are selected – http://prntscr.com/n1bw61 http://prntscr.com/n1bw9k
    Also, you need to create a Wishlist page manually – http://prntscr.com/n1bwph http://prntscr.com/n1bx0x (http://prntscr.com/n1bx6q)
    Please add this code in Theme Options > Custom CSS > Global custom CSS:

    .navbar-header .login-link .lost-password, .navbar-header .login-link .register-link {
        color: white;
    }

    http://prntscr.com/n1by8h

    Regards

    Avatar: Charles_Lim
    Charles Lim
    Participant
    March 25, 2019 at 06:46

    Yes, the pages were imported via tools of WC.

    The added custom CSS fixed the issue.

    However at homepage, when I add an item to wishlist and refresh the page, the number at the wishlist icon becomes “0”, while the item is already in wishlist. How do I fix this issue?

    Avatar: Rose Tyler
    Rose Tyler
    Support staff
    March 25, 2019 at 07:58

    Hello,

    Please, temporary disable cache and check one more time.
    If this doesn’t help, provide temporary wp-admin and FTP access so we can take a closer look.

    Regards

    Avatar: Charles_Lim
    Charles Lim
    Participant
    March 26, 2019 at 06:14

    I have provided requested details

    Please contact administrator
    for this information.
    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    March 26, 2019 at 13:42

    Hello,

    Your issue is related to WP Fastest Cache plugin Seems it caches the wishlist in the header. Contact plugin author to exclude wishlist from caching or try another cache plugin that does not have this problem (W3 Total cache, WPRocket).

    Regards

    Avatar: Olga Barlow
    Olga Barlow
    Support staff
    March 26, 2019 at 13:54

    P.S. We have added _wc_session_ to the exclusions in the cache plugin settings and seems it helped. Check, please.

    Regards

  • Viewing 9 results - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.Log in/Sign up

We're using our own and third-party cookies to improve your experience and our website. Keep on browsing to accept our cookie policy.